Minimal case

% http://tex.stackexchange.com/a/210664/13173 Do not have inputenc, since it is loaded with europecv package so defininig utf8 here
\usepackage{graphicx} % Required to draw the logo
\usepackage[right=2.5cm]{geometry} % language table impossible otherwise

% Define personal data
\ecvname{Masi} % No middle name


I get a complaint about package problem. I got this kind of error last time when I had problem with a package that contained the other package which I tried to include:

Document Class: europecv 2006/04/24 (beta+Unicode TeX detection) European curri
culum vitae class
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
./cv_masi_2.tex:3: Undefined control sequence.
\europecv.cls-h@@k ...pecv class.}}\inputencoding 
                                                  {utf8x}\let \@unprocessedo...
l.3 \usepackage
               {graphicx} % Required to draw the logo

./cv_masi_2.tex:3: LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.

l.3 \usepackage

I just updated my packages by tlmgr update --all --self but the problem remains. I am in OSX Yosemite which may be cause the problem, since I have not changed by anything in the code since last time. Possible changes in packages of MacTeX may also cause the problem.

Do you see any dependency problems in the minimal case?

  • 1
    @DavidCarlisle europecv loads inputenc, interestingly enough, it loats it with utf8x no matter which class option you use. – daleif Dec 12 '14 at 15:25
  • 1
    @daleif masi neglected to mention he is using xetex or luatex – David Carlisle Dec 12 '14 at 15:42
  • 1
    The implementation of a simple switch is fairly easy, please make a feature request containing a link to this question. – Johannes_B Dec 12 '14 at 15:54
  • 1
    You could always ping @DavidCarlisle here ;). – cfr Dec 15 '14 at 18:01
  • 2
    @cfr The ctan listing is essentially in error I'll ping them again to fix it, I have never used the class and don't have any access to any sources other than what's on ctan. I made a one line change to fix a bug that showed up with the 2014 inputenc release and located the original author to get permission to apply that patch. that doesn't mean I'm prepared to accept feature requests (or even bug reports:-) – David Carlisle Dec 15 '14 at 18:06

Presumably (you did not say) you are using lualatex or xelatex. These engines do not work with inputenc methods. The class seems to make assumptions about use of inputenc so it is only written for latex or pdflatex.

  • Thank you for your answer! This solves the problem! It was for the wrong engine. – Léo Léopold Hertz 준영 Dec 12 '14 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.