3

Egreg about arbitrary use of outfit but using truly utf8x

The europecv class arbitrarily decided that utf8 is not a good option and uses utf8x even if the passed option is utf8, which is of course stupid.

How can you work out the arbitrary use of utf8x in Europecv? Can there be made any changes in the actual package to support utf8, instead of utf8x?

CV is about publishing and it should be in the newest century, like here. I would like also have XeLaTeX support (now only pdflatex, discussion here) for Europecv which can be implemented at the same time and stop the intrinsic loading of inputenc.

13
  • You can also alter the source code of the class (of course with a different name) but since there is a simple typo in the code, contacting the maintainer seems to be simplest and most practical solution. – Johannes_B Dec 15 '14 at 18:00
  • I have already sent an email to the maintainer about the future development but this is a new case about arbitrary use of utf8x. I think it is better to have this here. Please, send your ticket here for the fix of the problem if it is a simple correction so we can evaluate it. – Léo Léopold Hertz 준영 Dec 15 '14 at 18:02
  • What do you mean by 'work out the arbitrary use of utf8x in europecv' if you are not asking how to get it fixed? Are you looking for a workaround? Or...? – cfr Dec 15 '14 at 18:04
  • 1
    @Johannes_B No, it was a conscious decision by the author, who didn't want utf8 to be used, because at the time it didn't support Greek. It was a very big mistake. – egreg Dec 15 '14 at 18:06
2

The class europecv says

\DeclareOption{utf8}{\AtEndOfClass{\inputencoding{utf8x}}}

which is a very big mistake. At the time the class was first released, utf8 didn't support direct input with Greek, which was the main reason for using utf8x. Since some years, utf8 does support Greek, so there's no reason for keeping the option in that way.

However, for back compatibility, a new option should perhaps be added, say realutf8.

You can coerce europecv into not loading inputenc with the utf8x option with the following kludge.

% trick to fool europecv into thinking XeTeX is used
\ifdefined\Umathchar\else\let\Umathchar\relax\fi

\documentclass[helvetica,narrow]{europecv} % no utf8 option!!!

% undo the effect of the trick
\ifx\Umathchar\relax\let\Umathchar\UNDEFINED\fi

\usepackage[utf8]{inputenc}

<rest of the preamble>

The best would be persuading the author of europecv into providing a realutf8 option that loads inputenc with the utf8 option.

1
  • There has been some good changes in Europecv. Some bugs which we reported to the developer has now been fixed. However, I tested this utf8 arbitrary use which still persists. They have not fixed it. – Léo Léopold Hertz 준영 May 26 '15 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.