2

Well, all is in the title. I don't want to use something like loading fontenc or anything like this, just enable \section{\textbf{\textsc{Experience}}}

EDIT :

Well thanks to all of you, I tried that :

\documentclass[10pt,a4paper]{moderncv}
\moderncvtheme[blue]{classic}                
\usepackage[utf8]{inputenc}
\usepackage{color}
\usepackage{amsmath}
\usepackage{amssymb}

\usepackage[inner=1.2cm,outer=1.2cm,top=0.4cm,bottom=0.4cm]{geometry}

\usepackage{sourcesanspro}
\renewcommand*{\sectionfont}{\Large\bfseries\scshape}

\firstname{\Large{Aaaa}}
\familyname{\Large{\textsc{Bbbb}}}
\title{\normalsize Iiiiiiiiiiiii }
\address{\textbf{113 iiiii}}{\textbf{000 Vvvvv}}  
\mobile{\textbf{0000000}}             
\email{[email protected]} 
\extrainfo{\textbf{bla bla}}  

\begin{document}
\pagestyle{empty}
\maketitle

\section{Experience}
\end{document}

Perhaps it works. "Experience" seem to be normal in bold. Using "fontenc" as I don't like that sourseanpro doesn't work (for me). What I need is result IN BOLD when deleting sourceandpro and renewcomand line and using \textsc in section.

Well I'm not satisfied and how to use "sans" option properly ?

6
  • Welcome to TeX.SX! A tip: You can use backticks ` to mark your inline code as I did in my edit.
    – Astrinus
    Commented Dec 15, 2014 at 20:03
  • "Just enable" requires a font that supports CAPITALIZED BOLD font. And this may require fontspec.
    – Werner
    Commented Dec 15, 2014 at 20:05
  • most font sets do not have bold caps and small caps font. If teh font does not exist, latex can not select it. Commented Dec 15, 2014 at 20:08
  • Please mark lines of code (not inline code but stretches of it) by indenting the code by 4 spaces. Easy way: highlight and click the {} button. Code tags do not work properly (e.g. you do not get something you can scroll and code is not formatted as a block).
    – cfr
    Commented Dec 15, 2014 at 22:10
  • To be honest, I don't really understand your question. If you delete the \renewcommand line then of course sections won't be typeset in bold because you are deleting the command which tells LaTeX to make them bold. (Unless bold is default for the class, which is presumably not the case or this wouldn't be a problem.) And it isn't clear what you mean by sourcesanspro not working. Do you mean that you get an error? Or that it compiles but the output is unexpected? Or that you just don't like the font? You say you are using fontenc but that's not in your code.
    – cfr
    Commented Dec 15, 2014 at 22:13

1 Answer 1

4

\renewcommand*{\sectionfont}{\Large\bfseries\scshape} will do the job, but as Werner said, you need a suitable font. sourcesanspro has bold small caps, for example (and I like it).

As karlkoeller says, since that's a sans serif font, you need to pass the class option sans:

\documentclass[10pt,a4paper,sans]{moderncv}

If you want a serif font instead, you could load the bold-extra package, or choose a font from those in this answer: https://tex.stackexchange.com/a/98581/61789

1
  • 1
    Also you have to load moderncv with the option sans Commented Dec 15, 2014 at 20:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .