0

This question already has an answer here:

I do not know why, but it seem that the tikz and pstriks packages are in conflict. Using both

\usepackage{tikz}
\uspepackage[usenames,dvipsnames]{pstricks}

When compiling, it returns me the following error:

!No room for a new \dimen

I list below the packages that I used:

\documentclass[a4paper]{article}
\usepackage[latin1]{inputenc}
\usepackage{color}
\usepackage{epsfig}
\usepackage{booktabs}
\usepackage{MnSymbol}
\usepackage{array}
\usepackage{makeidx}
\usepackage[all,dvips,graph]{xy}
\usepackage{hyperref}
\usepackage{tikz}
\usepackage[usenames,dvipsnames]{pstricks} 

Note that without one of tikz or pstricks, it will compile.

marked as duplicate by Thruston, Guido, Henri Menke, barbara beeton, Werner Dec 19 '14 at 20:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you look at the answer to this question? – Thruston Dec 19 '14 at 17:59
  • @Thruston: yes and adding etex it works, but I want to understand why: I'm not using too many packages... – amorvincomni Dec 19 '14 at 18:04
  • 2
    you don't need to use lots of packages, if you are using two of the biggest ones, and classic tex only has 256 dimen registers and latex uses up half of them before you start. – David Carlisle Dec 19 '14 at 18:15
  • 1
    don't load epsfig! (it won't help this problem, but don't load it anyway) – David Carlisle Dec 19 '14 at 18:16
  • 1
    Don't load color (TiKZ loads xcolor). Consider using utf8 and UTF8 encoding. – cfr Dec 19 '14 at 23:25