7

This is my minimal working example:

\documentclass{article} 

\usepackage{xeCJK}
\setCJKmainfont{Batang}

\begin{document}
        나는 남자를 이다
\end{document}

As you see, there are spaces between the Korean words. I compiled with XeLaTeX => PDF with XeTeX Version 3.1415926-2.5-0.9999.3 (MiKTeX 2.9) in TeXnicCenter. However there are no spaces in the outputfile. Help would be greatly appreciated.

6

You have to enable the CJKspace option:

\documentclass{article}

\usepackage[CJKspace]{xeCJK}
\setCJKmainfont{GungSeo} % a font with Hangul characters I have

\begin{document}

나는 남자를 이다

\end{document}

enter image description here

  • Thank You for your fast reply! I searched for ages.. It's working! – Felix Dec 21 '14 at 21:07
  • 4
    @Felix Consider that I can't read Chinese, Japanese or Korean; but I searched for space in the documentation, found the option and tried it. :) – egreg Dec 21 '14 at 21:17
  • I'll definitely do this next time too! – Felix Dec 21 '14 at 21:20
  • Thanks for this solution, I find that leaving some spaces between Chinese words actually can make the text more readable, even though it is not the standard practice for Chinese texts. – Yan King Yin Nov 26 '17 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.