3

My citations are not defined according to the log but then appear in this strange form in my biblography. This is the Code I use:

\NeedsTeXFormat{LaTeX2e}
\documentclass[ngerman,a4paper,pagesize,oneside,headinclude,parskip=half,DIV14,BCOR5mm,12pt,listof=totoc,bibliography=totoc]{scrbook}
\KOMAoptions{DIV=current}
\pagestyle{headings}
\usepackage{ngerman}        
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}        
\usepackage{lmodern}        
\usepackage[gen,right]{eurosym}     
\usepackage{graphicx} 
\usepackage{verbatim}
\usepackage{tabularx}
\usepackage{url}
\usepackage{color}
\usepackage{amssymb}
\usepackage{setspace}
\usepackage{scrhack} 
\usepackage{floatrow}
\usepackage{listings}
\usepackage{hyperref}
\usepackage{cite}

\ ...

\setcounter{tocdepth}{3}
\hyphenation{Sil-ben-trenn-ung}

\begin{document}
\frontmatter

\input{files/00_title.tex}

\linespread{1.25}

\tableofcontents

\listoffigures

\listoftables

\mainmatter
\input{files/ch1}

\appendix
\backmatter
\bibliographystyle{agsm} % Harvard-Style
\bibliography{literatur}

\end{document}

And from the bib-file:

@Article{thaler81,
Title                    = {Some Empirical Evidence on Dynamic Inconsistency},
Author                   = {Richard Thaler},
Journal                  = {Economic Letters},
Year                     = {1981},
}

In ch1, the reference is given by \cite{thaler81}. I used jabref to avoid problems/errors while citing.

generated bibliography

I'm new to Latex so this problem might have been there before but I could find or understand the solution. Thanks in advance!

  • 1
    Try to replace @Article by @article (small a). Or delete the aux file. – Sigur Dec 26 '14 at 19:19
  • You have to \usepackage{harvard} (before \usepackage{hyperref}). Remove \usepackage{cite}. – egreg Dec 26 '14 at 20:27
  • @Sigur - As far as BibTeX is concerned, @article and @Article are equally good -- capitalization does not matter for the spelling of the names of entry types and fields. – Mico Dec 27 '14 at 2:46
2

The advice that @egreg provides is good: Do not load the cite package if you want to use the agsm bibliography style. The cite package is meant to be used with numerical citation styles, whereas agsm is one of the style files distributed with the harvard citation management package and is meant to create authoryear-style citation call-outs.

Since you're also loading the hyperref package, I assume you would also like the citation callouts to be made into hyperlinks to the corresponding formatted entries in the bibliography. If that's indeed one of your objectives, you should not load the harvard package. Instead, load the har2nat and natbib packages. (As the package's name suggests, its purpose of the har2nat package is to "translate" citation macros of the harvard package into equivalent commands provided by the natbib package.) With har2nat and natbib loaded, citation callouts will automatically be made into hyperlinks -- something that won't happen if you load the harvard package.

For more information on this subject see, e.g., the posting Why do hyperref and harvard not work together properly?

1

You need to have

\usepackage{harvard}

instead of \usepackage{cite}; but it should be moved before \usepackage{hyperref}:

\usepackage{harvard}
\usepackage{hyperref}

% other settings

\setcounter{tocdepth}{3}
\hyphenation{Sil-ben-trenn-ung}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.