13

I got this error while running my tex file in XeLaTeX.

For recovering this i install fonts by running following code :

sudo apt-get install texlive-full
sudo apt-get install texlive-fonts-recommended

But the same error after installing.

The error message is :

! Package fontenc Error: Encoding file `eu2enc.def' not found.
(fontenc) You might have misspelt the name of the encoding.
See the fontenc package documentation for explanation.
Type H <return> for immediate help.

Using App : TeXMaker
OS        : Ubuntu 14.04 LTS
4
  • @ChristianHupfer Thanks.. How can i solve this issue..?
    – Rakesh KR
    Dec 27, 2014 at 7:18
  • 1
    Does installing the following work? sudo apt-get install texlive-xetex
    – scottkosty
    Dec 27, 2014 at 16:37
  • 1
    You probably shouldn't be loading fontenc if you are using XeLaTeX. Perhaps you meant to load fontspec instead?
    – cfr
    Dec 28, 2014 at 0:27
  • 2
    I'm absolutely sure that I'm not loading fontenc, just fontspec. I don't have xetex installed because I use lualatex. Strangely, installing texlive-xetex also fixed my issue. Is this a bug?
    – daaxix
    Jul 28, 2015 at 14:36

1 Answer 1

7

Make sure the package eu2enc.def is installed. In Ubuntu, it is part of the texlive-xetex package. Otherwise, you can install it using the texlive manager:

tlmgr install euenc

You could also try to install the package manually although I would not recommend it. The sources can be found here.

1
  • 2
    I'm using Fedora and I already have the texlive-xetex and texlive-euenc packages installed, however I still get this error.
    – Newbyte
    Jan 29, 2020 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .