3

After I enabled the [noend] option, the names on the 'List of Algorithms' and algorithm pseudocode is changed to 'List of noends' and 'noend' respectively. how do I change it back? Thanksenter image description here

\documentclass[11pt, a4paper, oneside]{memoir}
\usepackage[noend]{algorithm, algpseudocode}
\usepackage{blindtext}
\begin{document}
\listofalgorithms
\begin{algorithm}
\caption{HipHop} \label{alg:nb}
\begin{algorithmic}[1]
\ForAll{hip}
\State hop
\EndFor
\end{algorithmic}
\end{algorithm}
\end{document}

1 Answer 1

3

If you say

\usepackage[option]{packageA, packageB}

then option is passed to both packageA and packageB, which is not, typically, what you want.

Use

\usepackage{algorithm}
\usepackage[noend]{algpseudocode}

to correct the problem.

algorithms again!

1
  • @kenniy There's a greyed-out check mark at the top left of my answer, where the votes are shown. Click it to accept this answer. ;)
    – cfr
    Dec 29, 2014 at 2:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .