5

I am having a problem similar to this and this, but without using parskip, and only after a recent package update. The MWE

\documentclass{scrartcl}

\usepackage{amsmath,amsthm}

\theoremstyle{plain}
\newtheorem{thm}{Theorem}

\begin{document}

Some text before the theorem.

\begin{thm}
    Fun with theorems.
\end{thm}

Some text afterwards.

\end{document}

produces the following, certainly wrong spacing:

enter image description here

The space between the theorem and the preceding and succeeding text has gone. This only happens with scrartcl, not with article.

1 Answer 1

6

This is a known bug in the latest (released) version 3.14 of KOMA script, see http://www.komascript.de/release3.14 (in German, search for "scrsize10pt.clo"). EDIT: The bug is fixed in the (released and in TeXLive as of 20/01/2015) version 3.15.

One workaround (translated from the linked page) is to add
\csname @listi\endcsname after loading a scr* document class and after every use of the option fontsize.

Alternatively, you can edit the files scrsize10pt.clo, scrsize11pt.clo and scrsize12pt.clo to revert the change in this revision; the relevant bit is at the very end of the file, which should be changed to

%%% From File: $Id: scrkernel-paragraphs.dtx 1767 2014-06-26 09:20:18Z kohm $
\@ifundefined{@list@extra}{}{%
  \l@addto@macro{\@listi}{\@list@extra}%
  \let\@listI=\@listi
  \l@addto@macro{\@listii}{\@list@extra}%
  \l@addto@macro{\@listiii}{\@list@extra}%
  \l@addto@macro{\footnotesize}{\protect\add@extra@listi{ftns}}%
  \l@addto@macro{\small}{\protect\add@extra@listi{sml}}%
}
\@listi
\endinput
%%

(inserting everything from \@ifundefined to \@listi before \endinput).

3
  • Ok, in the future I'll have a look at "Bekannte Probleme Änderungen" first! Danke.
    – Deniz
    Commented Jan 2, 2015 at 8:58
  • It turns out that in a larger document (hard to reproduce with MWE), the problem remains. Is there any possible interference with other packages, or setting other KOMA script options? I cannot think of packages that set fontsize by themselves.
    – Deniz
    Commented Jan 2, 2015 at 9:10
  • Hard to say, since the fontsize mechanism runs pretty deep. I had limited success with the first option, but the second (fixing the scrsize files) worked for me. Commented Jan 2, 2015 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .