1

PDFlatex suddenly stopped generating the PDF and started returning a bunch of errors.

C:\fithesis2.cls:103: Font \filogo=fi-logo at 113.81102pt not loadable: Metric (TFM) file not found. [\font\filogo fi-logo at 40mm ]
C:\Program Files (x86)\MiKTeX 2.9\tex\generic\babel\babel.sty:149: Package babel Error: You haven't specified a language option. [...ry to proceed from here, type x to quit.}]
C:/diploma-thesis.tex:8: LaTeX Error: Option clash for package babel. [\usepackage]

Don't know what happened but it's not a syntax error in the document as far as I can tell.

All the packages worked fine previously - could a package be uninstalled without me knowing?

I need to troubleshoot this issue - tell me what information I should provide and I will paste it in the topic.

preamble:

\documentclass[12pt,oneside]{fithesis2} 
\usepackage{babel} % package for multilingual support
\usepackage[cp1250]{inputenc} % Windows OS encoding 
\usepackage[T1]{fontenc} \usepackage[plainpages=false,pdfpagelabels,unicode]{hyperref}
\usepackage[final]{listings}
\usepackage{graphicx}
\usepackage[slovak]{babel}
\usepackage[IL2]{fontenc}
\usepackage{caption}
\usepackage{chngcntr}
\counterwithout{figure}{chapter}


\lstset{
showstringspaces=false,
extendedchars=true,
frameround=fttt,
frame=single,
upquote=true,
breaklines=true
}

my bibliography database stopped working correctly for some reason, don't know why or how to fix it yet

C:\diploma-thesis.aux:93: Undefined control sequence. [\bibcite{citation}{24}]

Even an almost empty document like this wont compile:

\documentclass[12pt,oneside]{fithesis2} 


\begin{document}
testing text
\end{document}
  • What's your preamble? – Bernard Jan 4 '15 at 3:28
  • Added preamble to question. – Marek Andreansky Jan 4 '15 at 3:31
  • You have probably introduced a new package that also loads babel with another option and it is complaining about that. – percusse Jan 4 '15 at 3:34
  • tried removing one or both babels but it did not solve the issue. – Marek Andreansky Jan 4 '15 at 3:37
  • 1
    Removed \figure{SWOT analysis} from the tex file and now it compiles. Bloody hell, how could \figure have caused this ?! – Marek Andreansky Jan 4 '15 at 12:05
0

Removed

\figure{SWOT analysis}

from the document and everything compiles fine now. Don't understand how figure could have caused it, still need to find a way how use it somehow to number images :/

  • figure is an environment not a command. But your answer contradicts your claim that "Even an almost empty document like this wont compile:". Are you sure that your document compiles now without errors? Only because you get a pdf doesn't mean that your code/system is sane. – Ulrike Fischer Jan 4 '15 at 12:38
  • You're right - I am still getting errors but at least I am getting some form of pdf output. I tried compiling the document without a preamble (that did not help) and also tried compiling a different (almost empty) document. The almost empty document did not compile in SublimeText but after closing and reopening the text editor it generated a pdf once. I suspect that when I tried to compile the broken (figure) document the compiler got stuck in the middle and could not execute the second file. – Marek Andreansky Jan 4 '15 at 13:36
  • 3
    It is not a good idea to ignore errors: The next one can be fatal again and as you saw in this case it is difficult to debug a problem when a lot of "old" errors interfere. – Ulrike Fischer Jan 4 '15 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.