3

I am writing an article in LyX using the article.cls. I need to have some text before the title. But in the pdf output this text appears in a separate page and the title and the rest of the article is pushed down to a fresh new page. I want all of this in one page -- the first page.

How do I get rid of this page break between the text and title?

  • Hi and welcome, this is an often asked question. You either need to redefine the \maketitle command (only if you want to have that title layout multiple times) or create a title on your own. Of course, package titling might be of some help using \pretitle or \titlehooka. – Johannes_B Jan 6 '15 at 13:47
  • How do I create a title of my own! I am sorry but I am way dumb in all these than the dumbest. – aami Jan 6 '15 at 14:18
  • LaTeX is a bit like a big LEGO set. I haven't ome around to extend an answer of mine to just article titles, right now it covers different variant of customizing whole title pages. But the workflow is nearly the same. How to customize a titlepage. – Johannes_B Jan 6 '15 at 14:34
3

A dirty trick (I am too lazy to redefine \maketitle):

\documentclass[11pt]{article}
\usepackage{doc}
\title{Title}
\author{Author}
\date{\today}
\begin{document}
   Some {\em previous} text 

\begin{minipage}{\textwidth}
   \maketitle
\end{minipage}

\section{Introduction}
    Lore ipsum ...
\end{document}

MWE

In LyX, with the Insertmenu you can make first a minipage. Then define the title, authors and the date (in a a ERT if you want \today) inside the minipage:

MWE

Note: The LaTeX generated with Lyx produce a minipage with the [t]op option and a width of 1\columnwidth, where \title, \authour and \date are placed in the minipage (and not in the preamble as in the MWE), but the result is the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.