3

I use Emacs, with AUCTeX. When I type a double quote character " AUCTeX changes it to a pair of single quotes, either `` or ''. I often need double quotes in this document; how can I turn that behavior off? (I've peered at customize-group AUCTeX but none of the options seemed right.)

  • 1
    Pressing " twice gives a literal ". – egreg Jan 6 '15 at 14:21
  • 1
    Fair enough, but is there a way to stop it doing that in the first place? – Jim Hefferon Jan 6 '15 at 14:22
  • 2
    I think you can toggle the user option TeX-quote-after-quote so the feature egreg describes is reversed. – Mark Wibrow Jan 6 '15 at 14:32
  • @JimHefferon Did you customize TeX-quote-language-alist? – giordano Jan 6 '15 at 14:34
  • 1
    M-x set-variable RET TeX-quote-after-quote RET 0 RET seems does what is required (it can be any value that isn't nil) M-x set-variable RET TeX-quote-after-quote RET nil RET should return things to normal. – Mark Wibrow Jan 6 '15 at 14:41
2

Thanks to Mark Wibrow. Toggling the user option TeX-quote-after-quote does what I need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.