1

I have written a thesis, printing on the home-printer works fine, but for publishing, there are some problems concerning the embedding and fonttypes: I am using Miktex via TeXnic Center on Windows 7.

My current problem: I had a non-scaleable font first, now the normal text seems to be ok, but for formulas it doens't work. Here is a minimal example:

\documentclass[ 
   fontsize=12pt, 
   paper=a4, 
   german, 
   twoside=false 
     ]{scrbook} 

\usepackage[latin1]{inputenc} 
\usepackage[T1]{fontenc} 
\usepackage{lmodern}
\usepackage{cmbright}
\usepackage{ae}
\usepackage[ngerman]{babel} 


\begin{document} 

\chapter{testeins} 
aöüßLorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. 

\begin{equation} 
c = \sqrt{a^2 + b^2} 
\end{equation} 

\end{document} 

If I run this code, the formula enviroment is not a vector-font, therefore I can see the grid when I zoom in using a pdf reader. Analyzing it with pdffonts gives me:

name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
ZNESZZ+CMSSBX10                      Type 1            yes yes no       4  0
IKIYOW+CMSS12                        Type 1            yes yes no       5  0
[none]                               Type 3            yes no  no       6  0
[none]                               Type 3            yes no  no       7  0
[none]                               Type 3            yes no  no       8  0
[none]                               Type 3            yes no  no       9  0

For my thesis it is even more complicated. hfbright and cm-super are installed. If I remove the \usepackage{cmbright}, text and formulas are ok.

I would really appreciate your help, I am quite desparate by now...

closed as unclear what you're asking by Andrew Swann, user31729, Gonzalo Medina, user13907, yo' Mar 6 '15 at 16:03

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    You probably have a faulty installation of the CM-Super fonts. Try the method in tex.stackexchange.com/a/205641/4427 – egreg Jan 7 '15 at 13:23
  • that is exactly what I thought and reinstalled cm-super. Now it works for the minimal example :) (I had to re-install as user instead of admin..no idea why). Still there are problems with not-embedded fonts in my document. Should I discuss this here or open a new post (after some trial and error on my side first)? – user49017 Jan 7 '15 at 13:32
  • Don't use the package ae. Not doing so won't solve the problem, but it is deprecated. What does loading lmodern do given that you then load cmbright? – cfr Jan 8 '15 at 2:25
  • Use LuaTeX or XeTeX, switch to unicode and use unicode-math. – Martin Schröder Jan 8 '15 at 12:35