2

I'm trying to get mathlf option working for MyriadPro (installed with FontPro).

Here is a working preamble for lf

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage[medfamily,math,lf]{MyriadPro}
\usepackage[ttdefault=true]{AnonymousPro}

However, a subtitution of lf with mathlf which I would expect to keep just Lining figures for math mode, isn't working.

4

beamer, by default, changes the math font set-up to get acceptable sans serif math symbols. Use \usefonttheme{professionalfonts} to disable that. Thus, use

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage{amsmath}

\usefonttheme{professionalfonts}

\usepackage[medfamily,math,mathlf]{MyriadPro}
\usepackage[ttdefault=true]{AnonymousPro}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.