0

I have to add to the ToC the Bibliography and the Indexes (e. g., the Author index) in such a way that they have the same style of a Chapter without the Chapter number.

In particular, I need to add dots and page numbers of the Bibliography and the Indexes in the ToC.

The result I want to get is something like this

BIBLIOGRAPHY............................................3

AUTHOR INDEX...........................................42

What is the easiest way to do it?

Additional Notes

I have used imakeidx for the indexes.

This is the first part of the tex files I have to modify.

           \documentclass[twoside,openright, titlepage,numbers=noenddot, headinclude, %openany openright oneside twoside
            footinclude=true,cleardoublepage=empty, abstractoff, 
            BCOR=5mm,paper=a4,fontsize=11pt,%11pt,a4paper,
            ngerman,american,
    % bibliography=totoc
            ]{scrreprt}

This is what I can get for the moment

enter image description here

The Bibliography appears since I've used

\usepackage[nottoc, chapter]{tocbibind}

18
  • Hi and welcome, depends on the class and/or the used packages. If you are using a KOMA-class have a look at bibliography to toc and the related options.
    – Johannes_B
    Commented Jan 9, 2015 at 13:38
  • The class is scrreprt. I added this information in the question. I search a long but I couldn't find anything, unfortunately.
    – W4cc0
    Commented Jan 9, 2015 at 13:47
  • 1
    \KOMAoption{bibliography}{totoc}\KOMAoption{index}{totoc}
    – Johannes_B
    Commented Jan 9, 2015 at 13:49
  • btw: one of the options i just mentioned is uncommented in your code snippet. Go on an adventure and try testing a bit ;-) Nothing will explode by removing the comment char there.
    – Johannes_B
    Commented Jan 9, 2015 at 13:50
  • @Johannes_B thanks for your help, but I know how to add indexes and Bibliography to ToC. The real problem is that they appear just as headers without the dots and the page number and with the number of the chapter.
    – W4cc0
    Commented Jan 9, 2015 at 13:53

1 Answer 1

1

Workaround

I solved everything in a manual way: I've just created a ``part'' which resembles the bibliography. Anyway this works easy only if you do not have many references and do not need to change often the document.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .