3

The microtype package (with kerning=true) allows to use

\SetExtraKerning [ unit = space ] { encoding = {OT1,T1,LY1} }{ ' = {500, 400} }

to increase the kerning before (500) and after (400) the apostrophe. However, this also increases the spacing between the two halves of ". Typesetting:

He said ``Oh dear!''.   

yields a normal left double quote and a spaced out right double quote. How can we avoid this side effect while keeping the original effect, namely apostrophes with larger kerning?

I used

\documentclass{book} 
\usepackage[OT1,T1]{fontenc}
\usepackage[utf8]{inputenc}      
\usepackage{MinionPro}      
\usepackage[british,french]{babel}
\usepackage[kerning=true]{microtype} 
\SetExtraKerning[ unit = space ]{ encoding = {OT1,T1,LY1} }{ ' = {500,400} }
\begin{document}

Linné's naming scheme. He said ``Oh dear!''.    

\end{document}
  • 2
    Have you looked into using the csquotes package and its \enquote macro instead of doubled backticks and double apostrorphes? E.g., you might write He said \enquote{Oh dear!} AFAICT, the \enquote macro does a very good job with kerning-related matters in several languages. – Mico Jan 10 '15 at 18:00
  • @Mico Spacing is wrong with single quotes, still. – Manuel Jan 10 '15 at 18:34
  • @Manuel - I was assuming the OP is using a language convention that calls for double-quote marks. However, this assumption needn't be valid. Anyway, with french as the active language, \enquote produces guillemets rather than single of double apostrophes... – Mico Jan 10 '15 at 18:51
  • @Mico Yeah, I mean that it doesn't solve the particular case where one needs the single right quotes. It may not be important, I was just noting that. – Manuel Jan 10 '15 at 19:02
  • 1
    For the record, british would get you single quotes as outer quotes, although there would still be the problem of double quotes if you have inner quotation marks as well. (British and American conventions differ here - and this is reflected by csquotes.) So the example is a bad one, but the problem would still occur for, for example, He said, 'he screamed ''help!'''... – cfr Jan 11 '15 at 3:54
2

You can use the textcmds package which has the \ldq and \rdq commands for the double quotes, and simpler \qq{...} for double quoting some text:

Sample output

\documentclass{book} 
\usepackage[OT1,T1]{fontenc}
\usepackage[utf8]{inputenc}      
\usepackage[british,french]{babel}
\usepackage[kerning=true]{microtype} 
\usepackage{textcmds}
\SetExtraKerning[ unit = space ]{ encoding = {OT1,T1,LY1} }{ ' = {500,400} }
\begin{document}

Linné's naming scheme. He said ``Oh dear!''. 

Linné's naming scheme. He said \ldq Excellent\rdq\ or better \qq{Excellent}

\end{document}

Addition This does not turn off any features you previously had, just adds easier access to them. In particular should you wish to kern these new double quotes you just add appropriate microtype rules. Checking the textcmds.sty file one finds that \ldq is \textquotedblleft, the latter is what is need for the character specification of the microtype rule. Here is an exaggerted example:

Sample output

\documentclass{book} 
\usepackage[OT1,T1]{fontenc}
\usepackage[utf8]{inputenc}      
\usepackage[british]{babel}
\usepackage[kerning=true]{microtype} 
\usepackage{textcmds}
\SetExtraKerning[ unit = space ]{ encoding = {OT1,T1,LY1} }{
  ' = {500,400},
  \textquotedblleft = {1000,1100},
  \textquotedblright = {1100,1000}
  }
\begin{document}

Linné's naming scheme. He said \ldq Excellent\rdq\ or better \qq{Excellent}.

\end{document}

By the way, I hope you realise that

\usepackage[british,french]{babel}

makes french the main language. If you want british as the main language

\usepackage[main=british,french]{babel}
  • Thank you! The solution answers the question to 80%. It is not 100% because now microtype cannot be used to increase the kerning around the double quotes. But it is a useful fix that solves most of the problem. – Motion Mountain Jan 19 '15 at 5:30
  • @MotionMountain Please see the updated answer, nothing was switched off. – Andrew Swann Jan 19 '15 at 8:15
  • Now the answer is complete and perfect - thank you! – Motion Mountain Jan 20 '15 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.