6

I'm trying to use the baskervaldx font in XeLaTeX; however it doesn't kern properly. With LaTeX it works as supposed.

What is the right way to load the Baskervaldx font?

With LaTeX, default install on Linux

\documentclass[12pt]{article}
\usepackage{Baskervaldx}
\begin{document}
\textsc{Hello} World

Top
\end{document}

Baskervaldx -- LaTeX

With XeTeX, otf files copied to ~/.fonts

\documentclass[12pt]{article}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text]{Baskervaldx}
\begin{document}
\textsc{Hello} World

Top
\end{document}

Baskervaldx XeTeX

  • 2
    The kerning is fine with luatex, but with xetex I get the same bad kerning you noticed. – Thérèse Jan 11 '15 at 2:08
  • Note that if things are properly set up, you shouldn't need to copy the files to another directory to use them - the system should know about the TeX directories (unless, of course, you don't wish it to). – cfr Jan 11 '15 at 2:59
  • 1
    This font is odd in other ways too. Unless you want “poetry” to become “pœtry,” be sure to turn off the rlig feature. Something like this should produce reasonable results, apart from the kerning problem in xetex: \setmainfont{Baskervaldx}[Ligatures=NoRequired,Numbers=OldStyle,SmallCapsFeatures={LetterSpace=6}] – Thérèse Jan 11 '15 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.