1

I collected a lot of references in an external bib-file, where I keep both references and resources, along side with cite-sources and bibliography items. Resources and Links shall go to the footnote area of each page, while references should appear at the References-pages of the whole document.

There is no problem to create normal footnotes and citation in general works well. But I am unable to get \footcite{...} working as I want. It either shows just a sign with a hyperref to the last page, where the reference is mentioned. When I set style=verbose in the usepackage section, the footnote shows the whole reference-info but all the other \cite notes in the text too, what clearly isn't what I intend. Because of special formatting and other advantages I use the biber backend.

\documentclass[12pt,hyperref]{article}
\usepackage{setspace}
\usepackage{url}
\usepackage[backend=biber, style=verbose]{biblatex}
\usepackage{graphicx}
\author{Max Maximus}
\title{}
\bibliography{somebibfile}
\pdfoutput=1

\begin{document}
Duis autem vel eum iriure dolor\cite{colomb_ontology_2007}
Ut wisi enim ad minim veniam, quis\footcite{handa_nepomuk_2013} 
dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat.   

\printbibliography
\end{document}

Bib file:

@book{colomb_ontology_2007,
    title = {Ontology and the semantic web},
    isbn = {9781586037291},
    pagetotal = {258},
    publisher = {{IOS} Press},
    author = {Colomb, Robert M.},
    date = {2007}
}
@letter{handa_nepomuk_2013,
    title = {Nepomuk in 4.13 and beyond},
    url = {https://mail.kde.org/pipermail/nepomuk/2013-December/004858.html},
    type = {E-mail},
    author = {Handa, Vishesh},
    urldate = {2014-12-01},
    date = {2013-12-12},
}

To summarize:

  • I want a footcite to conatin the full cite string as it would appear in the bibliography section
  • Sources cited with footcite shouldn't appear in the printbibliograhy section
  • \cites should use the normal style with a number to the item in the printbibliography section (of course with the later option to change the abbreviation appearance)

Footnote appearance I wish

Footnote appearance I wish

Footnote appearance without style=verbose (I don't want this)

Footnote appearance without style=verbose (I don't want this)

Normal cite, how it should be without style=verbose

Normal cite, how it should be without style=verbose

  • 1
    Welcome to TeX.SX! – egreg Jan 11 '15 at 13:25
  • @moewe Yes, that would probably solve it – SeDav Jan 11 '15 at 13:39
  • Maybe using \footfullcite instead of \footcite (together with the numeric style) is for you then. – moewe Jan 11 '15 at 13:39
  • @moewe Oh thank you very much, how could I have overlooked that! Never used it until now. If you convert your comment to an answer, I'd mark it as solved: BTW removing it from printbibliography, will be another issue, but I have seen ways to do it here . – SeDav Jan 11 '15 at 13:44
  • I had missed the point about removing it from \printbibliography, sorry. In this case, I think it is more convenient to come up with a new command. Give me a few minutes, maybe I can come up with something. – moewe Jan 11 '15 at 13:46
2

If you just want to have a full citation in footnotes, you can go with \footfullcite, but if you also want to exclude entries cited in footnotes from the bibliography, it is probably more convenient to define a new command that does both of these things at the same time.

We first set up a category called skipbibliography.

\DeclareBibliographyCategory{skipbibliography}

Then we define \myfootcite to add the cited entry to the skipbibliography category and cite it in the \footfullcite manner (this command is just \footfullcite with one line added)

\DeclareCiteCommand{\myfootcite}[\mkbibfootnote]
  {\usebibmacro{prenote}}
  {\addtocategory{skipbibliography}{\thefield{entrykey}}%
   \usedriver
     {\DeclareNameAlias{sortname}{default}}
     {\thefield{entrytype}}}
  {\multicitedelim}
  {\usebibmacro{postnote}}

If yo now want to print the bibliography, use

\printbibliography[notcategory=skipbibliography]

to exclude entries of the skipbibliography category.

MWE

\documentclass{article}
\usepackage[backend=biber, style=numeric, defernumbers]{biblatex}
\addbibresource{biblatex-examples.bib}

\DeclareBibliographyCategory{skipbibliography}
\DeclareCiteCommand{\myfootcite}[\mkbibfootnote]
  {\usebibmacro{prenote}}
  {\addtocategory{skipbibliography}{\thefield{entrykey}}%
   \usedriver
     {\DeclareNameAlias{sortname}{default}}
     {\thefield{entrytype}}}
  {\multicitedelim}
  {\usebibmacro{postnote}}

\begin{document}
Lorem ipsum \cite{cicero} dolor\myfootcite{wilde} sit amet. 

\printbibliography[notcategory=skipbibliography]
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.