2

I am doing my first steps trying to write Hebrew articles with LyX (Or any other solution). I am using Mac and do not know what to do after I have download LyX. Thanks

  • 1
    Welcome to TeX.SX! Sorry, but this question is to vague. You have to define some clear problem which we can fix for you. Like this, I can just say: Read wiki.lyx.org/LyX/Tutorials and tex.stackexchange.com/q/11 and finally tex.stackexchange.com/questions/tagged/hebrew+lyx – LaRiFaRi Jan 12 '15 at 15:01
  • I am looking for the best solution in which I can write in Hebrew – newbie Jan 12 '15 at 16:27
  • 1
    I would say the first step is to try to compile LyX's Hebrew documents. They are in lib/doc/he/. If you cannot do that, you probably need fonts. I don't know how that works on Mac. – scottkosty Jan 12 '15 at 17:42
2

Given Macs use unicode by default, your simplest solution is to use XeTeX as the typesetting engine.

See my example at Two fonts for two languages using lyx which uses Hebrew.

0

Here's what I did on Pop!_OS 19.10:

I installed LyX and texlive-full from the repo and culmus-latex-0.7

  • In Tools->Preferences->Editing I set it to use keyboard map with null as primary (for English. It works better than american for me) and hebrew as secondary
  • In Tools->Preferences->Output->LaTeX->"Use LaTeX font encoding" I enabled it and set it to HE8 (which is an unnecessary step, so skip this)
  • In Tools->Preferences->File Formats->"Default Output Formats"->"With TeX Fonts" I set to "PDF (pdflatex)"

In Document->Settings->Fonts:

  • I didn't use non-TeX fonts (leave it on the default: TeX fonts) LaTeX font encoding: "None (no fontenc)"
  • I set the Default font to sans serif
  • For the Roman, Sans Serif, Typewriter fonts I set them all to Computer Modern fonts because I found through trial and error that they work, though some others might work too (Latin Modern also appears to work). Math I left on automatic.

Of course I saved all of the changes I made in Document->Settings as Document Defaults.

In order to be able to render my LyX document that I previously created with a different configuration all I had to do was change the fonts and add that line to the preamble.

I also discovered that I need to switch back from Hebrew to English before inserting math to avoid strange artifacts from appearing in the PDF.

I added a version of these instruction to the LyX wiki: Hebrew on Linux: Pop!_OS 19.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.