0

Newbie here. I'm running MikTeX 2.9 on Win8.1 and I'm trying to setup TeXstudio to implement some of the suggestions in "The not so short intro..." by Oetiker et al.

Since IEEEtrantools aren't in MikTeX I followed some instructions I found somewhere and installed the files to "C:\Local TeX Files." I managed to get the MikTeX package pointed in the right direction (and registered and updated) so this code works just like Oetiker said it would (when run in TeXstudio):

\begin{IEEEeqnarray}{rCl}
    a & = & b + c
    \\
    & = & d + e + f + g + h
    + i + j + k \nonumber\\
    && +\: l + m + n + o
    \\
    & = & p + q + r + s
\end{IEEEeqnarray}

The problem is that in TeXstudio, the command:

\usepackage[retainorgcmds]{IEEEtrantools}

has the package name underlined and a pop-up says it's not found. Given that, I guess it's no surprise that the \begin{IEEEeqnarray} and "&"s are highlighted in pink.

It is a little surprising that C:\Users...\AppData\Roaming\texstudio\IEEEtrantools.cwl is there. It's possible that got there when I checked the box in config\completion for the tools but I kind of doubt it. It stays there when I uncheck the box. There are some other files in there that look promising like "miktexPackageNames.dat." That file has "IEEEtran" since I tried that first but the tools didn't get in there.

Another clue would seem to be that "IEEEtrantools.cwl" is listed in "options/configure/completion" but checking the box makes no difference.

Maybe I can just add the tools name to the dat file? -> Nope. That file gets regenerated when studio is closed.

So it seems that TeXstudio is not scanning the "Local TeX Files" folder even though it is registered in MikTeX. I also tried copying the *sty file to the folder my *.tex file is in.

I've seen some related questions but nothing quite the same.

1

the package name underlined and a pop-up says it's not found

With a MikTeX installation, TXS checks the presence of a package by analyzing the result of mpm --list. I assume that this does not cover packages in a local tex folder. You may disable package checking at Options -> Editor -> Inline Checking -> Packages.

There are some other files in there that look promising like "miktexPackageNames.dat."

This file maps the MikTeX package names to the .sty and .cls file names. It's used as cache for a fast lookup. It's automatically updated in a background process, therefore, manual modifications do not persist.

It is a little surprising that C:\Users...\AppData\Roaming\texstudio\IEEEtrantools.cwl is there.

TXS tries to detect the commands defined in a style file. These are stored in a .cwl file. See the TeXstudio FAQ and the link therein for more details. Depending on the complexity of the sty files, it is not possible to extract all valid commands. You may add missing commands to the cwl file. To see the changes, restart TXS afterwards.

  • So there is no solution then. What you suggest just decreases functionality and only gets rid of the underline. The pink highlighting remains. btw, I can't help wondering why this isn't a good question especially considering that there seems to be no answer. I already understood what cwl files do. What is surprising is that even though there is one was added, TXS doesn't recognize seem to recognize it. I wonder if it needs to be in a different location. – M T Feb 7 '15 at 17:00
  • There's two parts here. 1) The package checking (underline). Since mpm --list does not contain your local tex data, you cannot do anything about it (except disabling the checker). 2) The command checking against the cwl file ('pink' highlighting). As described above and in the FAQ, automatic generation of cwls cannot detect all commands. In particular, it cannot add any semantics. You are free to add that yourself. Adding \begin{IEEEeqnarray}{cols}#\math,array and \end{IEEEeqnarray} to the cwl will probably do what you are looking for. Don't forget to restart TXS after adding these. – Tim Hoffmann Feb 8 '15 at 18:30
  • Strangely, I encountered exactly the same problem a couple of years back and have now IEEEtrantools.sty sitting in a subfolder. To my knowledge MikTeX knows nothing about this, and my IEEEtrantools are still the version I plucked off the net (long forgotten where from). The problem I have is that this is a non-standard state of affairs, and the question I would like to ask the community is: is IEEEtrantools in widespread use, and if so why, and are there packages that will provide the functionality IEEEtrantools provides? I suppose one might also wonder why MikTeX does not support trantools. – Reinhard Neuwirth Aug 7 '15 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.