2

How can I make fc package work with TeX 3.1415926 (TeX Live 2013/Debian) on ubuntu ? In fact I want to use African fonts and I found this document. Can somebody tell me how to install this fc package or its dependencies ?

1

1 Answer 1

3

Have you tried it like this?

% arara: pdflatex

\documentclass{article}
\usepackage[T4]{fontenc} % loading the fc package

\begin{document}
    \B{D}\B{d}\B{H}\B{h}\B{t}\B{T}%
    \m{b}\m{V}\m{C}\m{c}\m{D}%
    \M{d}\M{D}%
    \m{d}\m{E}\m{e}%
    \M{E}\M{e}%
    \m{f}\m{F}\m{G}\m{g}\m{I}\m{i}\m{J}\m{j}\m{K}\m{k}\m{N}\m{n}\m{o}\m{O}\m{P}\m{p}\m{s}\m{S}%
    \M{t}\M{T}%
    \m{t}\m{T}\m{u}\m{U}\m{Y}\m{y}\m{z}\m{Z}%
    \T{E}\T{e}\T{O}\T{o}
\end{document}

enter image description here


When zooming in, you will notice a quite bad quality of the letters (they are not scalable). So you might want to search the letters you need on http://detexify.kirelabs.org/classify.html and use them like this:

% arara: pdflatex

\documentclass{article}
\usepackage[T1]{fontenc} % for \DJ\DH\dj
\usepackage{lmodern}
\usepackage{tipa} % for \textcrh

\begin{document}
 \DH\DJ\dj\textcrh\dots
\end{document}

enter image description here


And you can always go the unicode way with some font you like:

% arara: lualatex

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Linux Libertine O}

\begin{document}
    \symbol{"0189}\symbol{"0111}\symbol{"0126}\symbol{"0127}\symbol{"0167}\symbol{"0166}\symbol{"0253}\symbol{"0181}\symbol{"0187}\symbol{"0188}\dots
\end{document}

enter image description here

3
  • Right, seem to work. But I'm using garamondx font. I'm getting errors like ! LaTeX Error: Command \m unavailable in encoding T1. though I don't mention T1 in fontenc options. What's wrong ?
    – sk001
    Jan 13, 2015 at 12:36
  • 1
    @sk001 From the garamondx doc: "The package uses T1 encoding—this is built into the package and need not be specified separately." The symbols in my first example use the T4 encoding. I do not know, if garamondx does support those symbols. I guess you will have to load another font or symbol package for this.
    – LaRiFaRi
    Jan 13, 2015 at 13:40
  • @sk001, I wouldn't recommend using fc with garamondx because it's made to look like Computer Modern, not Garamond. I would find a Unicode font that has all the symbols you want and load it with fontspec using XeLaTeX, as @LaRiFaRi suggests. However, you don't need to use \symbol{}, which is really cumbersome -- you can just enter the symbol directly if it's on your keyboard. If it's not, you can use a keyboard overlay or copy and paste. Jan 16, 2015 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.