2

I am writing the following equation:

\begin{displaymath}
\begin{split}
  MA &= MAAMB + MACAMB\\
  \Leftrightarrow MA &= (MAAM + MACAM)B\\
  \Leftrightarrow (MAAM + MACAM)^{-1}MA &= B
\end{split}
\end{displaymath}

The problem is that I cannot introduce another & to separate the equivalent sign (the \Leftrightarrow) from the line itself; i.e. to create a distance between the sign and the beginning of the formular. I want that the equivalent signs are aligned similar the the equal signs. Is there a way to accomplish this?

I read somewhere that the eqnarray is deprecated? Is this true? Even using an eqnarray is not optimal, because the cells are left aligned.

1
  • You could use the align environment.
    – Seamus
    Commented Jul 4, 2011 at 14:27

3 Answers 3

4

What you are looking for is the alignat* environment:

\begin{alignat*}{2}
&                       &MA                    &= MAAMB + MACAMB\\
&  \Leftrightarrow\quad &MA                    &= (MAAM + MACAM)B\\
&  \Leftrightarrow      &(MAAM + MACAM)^{-1}MA &= B
\end{alignat*}
1

Since you are using split, then you are using amsmath, then forget about displaymath, use equation* instead (then it is eqsy to enable numbering if needed). In your case also change split to aligned or alignedat, that enable support for several alignments, split only support one alignment.

It is recommended not to use eqnarray as it is flawed and not typographically consistent with the other math constructions.

1

You can use an array inside an equation:

\documentclass{article}
\usepackage{amsmath}
\begin{document}
\begin{equation}
  \begin{array}{lcr}
& MA &= MAAMB + MACAMB\\
  \Leftrightarrow & MA &= (MAAM + MACAM)B\\
  \Leftrightarrow\quad & (MAAM + MACAM)^{-1}MA &= B\\
  \end{array}
\end{equation}
\end{document}

If you want more spacing, replace \quad with \qquad

2
  • the spacings on the =-s will be wrong
    – daleif
    Commented Jul 4, 2011 at 19:27
  • @daleif ah you're right. I guess lcl would be better there...
    – Seamus
    Commented Jul 5, 2011 at 21:26

You must log in to answer this question.