3

Introduction

I'm using updated TeXlive 2014 and the fontawesome package version is 3.1.1.

The newest version of FontAwesome font is 4.2.0 and it contains icons for Linux and StackExchange.

So I downloaded the bundle from here and just replace the FontAwesome.otf in

/usr/local/texlive/2014/texmf-dist/fonts/opentype/public/fontawesome

After that I run texhash.

The code

I have a (huge) tex file with a lot of material and also the code

\def\faSkype{{\FA\symbol{"F17E}}}
\def\faSE{{\FA\symbol{"F18D}}}
\def\faLinux{{\FA\symbol{"F17C}}}

It compiles with no error and the PDF output is OK, as we can see below.

enter image description here

The problem

I have no idea why the MWE below does not work. The same problem without fontspec.

\documentclass{report}

\usepackage{fontawesome}
\usepackage{fontspec}

\def\faLinux{{\FA\symbol{"F17C}}}
\def\faSE{{\FA\symbol{"F18D}}}
\def\faSkype{{\FA\symbol{"F17E}}}

\begin{document}
Linux icon: \faLinux

StackExchange icon: \faSE


Skyp icon: \faSkype
\end{document}

lualatex on the code above produces (icons missing)

enter image description here

I found here in TeX.SE a lot of topics but that solutions didn't work for me. I'd deleted the system font installed version.

  • You should not have installed the font to /usr/local/texlive/2014/texmf-dist/fonts/opentype/public/fontawesome. It should be in /usr/local/texlive/texmf-local/fonts/opentype/public/fontawesome. – cfr Jan 14 '15 at 2:04
  • Have you deleted ~/.texlive2014? – cfr Jan 14 '15 at 2:07
  • @cfr, no, I didn't delete. I'll move the font file. After that what should I run? texhash? updmap-sys? – Sigur Jan 14 '15 at 2:09
  • @cfr, I moved the font file and deleted the folder on my home. After only this I run only lualatex again and no success. – Sigur Jan 14 '15 at 2:14
  • Try installing the .ttf version as a system font. That's what I've got (and it is 4.2.0) and your MWE compiles fine with both lualatex and xelatex. – cfr Jan 14 '15 at 2:36
2

Maybe a temporary fix would be to work locally with the latest FontAwesome version. Grab the latest version of the font at http://fortawesome.github.io/Font-Awesome/ and copy the file named "fontawesome-webfont.ttf" in a sub-folder named "fonts" (or any other name) of your LaTex document location. Then, instead of passing through the fontawesome package, you can load and use the font manually like this (based on the MWE you provided):

\documentclass{report}

\usepackage{fontspec}

\newfontfamily{\FA}[Path = fonts/]{fontawesome-webfont}

\def\faLinux{{\FA\symbol{"F17C}}}
\def\faSE{{\FA\symbol{"F18D}}}
\def\faSkype{{\FA\symbol{"F17E}}}
\def\github{{\FA\symbol{"F092}}}

\begin{document}

\noindent
Linux icon: \faLinux \\
StackExchange icon: \faSE \\
GitHub icon: \github \\
Skype icon: \faSkype

\end{document}

Here is the output I get for this MWE:

enter image description here

It doesn't solve your problem globally for your system though... LuaLatex is probably grabbing an older version of the font package along the way that override the new one you've installed.

  • Welcome to TeX.SX! Could you show us the output of your document as a screenshot? – user31729 Apr 13 '15 at 20:10
  • @ChristianHupfer Of course. There you go. – Jean-Sébastien Apr 13 '15 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.