2

I am using the light option of the kpfonts package and I want to display the ſ letter only in a section of the text. Can I switch from the normal option to the veryoldstyle option?

\usepackage[light]{kpfonts}

2
  • Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – cfr Jan 15 '15 at 3:46
  • You can use s=. But something like \renewcommand{\rmdefault}{jkplos} should work - see the documentation (right at the end). – cfr Jan 15 '15 at 3:57
2

As you did not provide an MWE I had to guess some things. My solution simply defines a new environment oldstyle which activates the vos-Versions of the kpfonts and switches to normalfont (i.e. plain Roman).

\documentclass{scrartcl}
\usepackage[light]{kpfonts}

\newenvironment{oldstyle}{%
  \renewcommand\rmdefault{jkplvos}%
  \renewcommand\sfdefault{jkpssvos}%
  \renewcommand\ttdefault{jkpttvos}%
  \normalfont
}{}

\begin{document}
This is a newstyle test file.

\begin{oldstyle}
  This is an oldstyle test file.
  One can get the round s= like s=hown.
  \textsf{Sans-} and \texttt{typewriter-fonts} work here, too.
\end{oldstyle}

This is newstyle again.
\end{document}

Note that depending on your wishes you can use os instead of vos if you only want the oldstyle instead of the veryoldstyle option. Note further that I change the sans- and typewriter-fonts to the non-light vos-versions as there does not seem to be a difference between light and non-light sans.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy