0

I am using LaTeX+Biber+Texmaker under Ubuntu. I have recently upgraded Ubuntu from 12.10 to 14.10, and I am having some issues with some of my LaTeX documents after that. I thought the issue might be due to missing LaTeX packages, therefore I installed also texlive-full (http://packages.ubuntu.com/utopic/texlive-full), which gathers all the tex packages in the Ubuntu repository. The error log returns a set of errors as follows:

Package biblatex Info: Trying to load bibliographic data...
Package biblatex Warning: File 'phd_drupal_cbpp_confirmation.bbl' is wrong form
at version - expected 2.4.
Package biblatex Info: ... file 'phd_drupal_cbpp_confirmation.bbl' found.
(./phd_drupal_cbpp_confirmation.bbl
! Undefined control sequence.
<argument> ...refsection @entry@\blx@slist@scheme
l.41 \endentry
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.
! Undefined control sequence.
<argument> ...refsection @entry@\blx@slist@scheme
l.41 \endentry
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.
! Undefined control sequence.
<argument> ...refsection @entry@\blx@slist@scheme
l.61 \endentry
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.
! Undefined control sequence.
<argument> ...refsection @entry@\blx@slist@scheme
l.61 \endentry
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

[...]

The preamble of the main document is as follows:

\documentclass[a4paper,12pt, oneside]{report}

%% Include options to break urls
\usepackage[hyphens]{url}
\usepackage[style=apa, backend=biber, urldate=long]{biblatex}
\DeclareLanguageMapping{british}{british-apa}
\addbibresource{bibliography.bib}
\usepackage[british]{babel}
\usepackage{hyperref}

\usepackage[top=1in, left=1.5in, right=1in, bottom=1in]{geometry}
\usepackage[utf8]{inputenc}
\usepackage[usenames,dvipsnames]{color}
\usepackage{setspace}
\usepackage{titlepic}
\usepackage{graphicx}
\usepackage[nodayofweek]{datetime}
\usepackage{float}
\usepackage{booktabs}
\usepackage{tablefootnote}
\usepackage{multirow}

\usepackage{csquotes}
\usepackage{setspace}

% Ordinals and numbering
\usepackage[super]{nth}
\usepackage[gen]{eurosym}

%TO-DO: Check package dependencies
%\usepackage{siunitx}

%% Manual hyphenation
\hyphenation{fle-xi-bi-li-ty}
\hyphenation{qua-li-ty}
\hyphenation{em-pha-si-se}


%% Style
%% Paragraph settings
\setlength{\parskip}{0.9em}

% Checkmarks
\usepackage{tikz}
\def\checkmark{\tikz\fill[scale=0.4](0,.35) -- (.25,0) -- (1,.7) -- (.25,.15) -- cycle;} 


\usepackage{titlesec}
\setcounter{secnumdepth}{4}
\titleformat{\paragraph}
{\normalfont\normalsize\bfseries}{\theparagraph}{1em}{}
\titlespacing*{\paragraph}
{0pt}{3.25ex plus 1ex minus .2ex}{1.5ex plus .2ex}


[...]

The most similar issue I have found is Biblatex with biber backend results in undefined control sequences but not with bibtex backend , but I am not sure if it is related to the same problem.

Any ideas on what could be the issue?

Thank you very much!

  • Did you try deleting your auxiliary files (particularly the .bbl file)? The warnings above suggest that the Biber/biblatex version has changed and your files therefore need updating. – Joseph Wright Jan 15 '15 at 12:24
  • Thanks a lot, @JosephWright! That worked! The document compiles now. However, I am still having an issue while running biber from Texmaker (I am not sure if it is related to this): Possible precedence issue with control flow operator at /usr/share/perl5/Biber/LaTeX/Recode.pm line 395. Any idea what the reason could be? – drozas Jan 15 '15 at 12:30
  • Looking at aur.archlinux.org/packages/biblatex-biber this last error seems to be due to another issue, so I will take a look at it in a separate one. – drozas Jan 15 '15 at 12:46
1

This was solved after deleting the auxiliary files, as suggested by @Joseph Wright. It seems to be necessary after upgrading the version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.