2

If I load inputenc in combination with hyphsubst the hyphenation works partially. It works for many words, but it does not work for 'Starrkörpertransformationsparameter' if inputenc is loaded

hyphenation working:

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

\documentclass[ngerman]{scrbook}

% \usepackage[utf8]{inputenc}
\usepackage{babel}

\begin{document}
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
\end{document}

hyphenation does not work:

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

\documentclass[ngerman]{scrbook}

\usepackage[utf8]{inputenc}
\usepackage{babel}

\begin{document}
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
\end{document}
1
  • Welcome to TeX.SX! The problem is that you don't have also \usepackage[T1]{fontenc}
    – egreg
    Jan 16, 2015 at 13:18

1 Answer 1

2

It's not a problem due to inputenc. You also need \usepackage[T1]{fontenc} or TeX won't hyphenate words past an accent.

In your example without inputenc, hyphenation points are found, but just because the accented characters are ignored.

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

\documentclass[ngerman]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\begin{document}
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
  Starrkörpertransformationsparameter
\end{document}

enter image description here

Slightly different results are obtained if \usepackage{microtype} is loaded, but this is expected; here's the result, the text is the same as before, the preamble is

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

\documentclass[ngerman]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{microtype}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .