2

When I open a .tex file with Texmaker under Win8.1, that was created on a Mac using TexShop, I get the following error:

It seems that this file cannot be correctly decoded with the default encoding setting (UTF-8)

Different choices for an encoding option are then proposed. I select "macintosh", and the file opens correctly.

However, after saving it, when I open it again, the same error pops up again.

I guess I have to open the file with "macintosh" but save it with another encoding. I did not find a way to do so.

Do you have any idea?

  • You should be using UTF-8 in TeXShop, too. (I thought this was default but maybe not.) – cfr Jan 19 '15 at 21:57
  • @cfr The default encoding of TeXShop is Mac OS Roman (corresponding to the applemac option of the inputenc package). – Franck Pastor Jan 19 '15 at 22:14
  • @fpast Really? I wonder why. In any case, the OP should certainly change it, if so. – cfr Jan 19 '15 at 22:27
  • @cfr I correct myself: the default encoding of TeXShop was indeed Mac OS Roman… until version 3.15. Since this version the default has been changed to Iso Latin 9. Still a 8-bit encoding, essentially for backward compatibility with old 8bits-encoded TeX files, but less specific than Mac OS Roman. – Franck Pastor Jan 19 '15 at 22:41
2

I just realized that Texmaker proposes a simple way of doing it. There is a Unicode converter in the "Tools" toolbar.

There, one selects the .tex file to open and specifies the original encoding. The file is then automatically converted!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy