0

I installed MiKTeX and Texmaker on office and personal computers, but the two computers generate different top page margins .pdf file using the same .tex file?

The office computer generates the right one, but my personal computer generates the wrong one with bigger top page margin. The MiKTeX version of office computer is older. Maybe it is related with some packages, but I'm not sure which one to be updated.

How could I solve the problems?

EDIT: added code (begin of the tex file) from comment to question:

\documentclass[journal]{IEEEtran} 
\usepackage{graphicx} 
\usepackage{url} 
\usepackage{amsmath} 
\interdisplaylinepenalty=2500 
\usepackage[english]{babel} 
\usepackage{array} 
%\usepackage{flushend} 
\hyphenation{industrial electronics IEEEtran} 
\usepackage[usenames,dvipsnames]{color} \usepackage[font=footnotesize,caption=false,farskip=0mm,captionskip=0mm,nearskip‌​=0mm]{subfig}
  • Update both distributions to the newest ones and see if it helps. (I don't think it has got anything to do with Texmaker; that's just an editor.) – Svend Tveskæg Jan 20 '15 at 4:08
  • 5
    Did you specify the paper size in the \documentclass directive or in \usepackage[…]{geometry}? Systems can be set up with different defaults depending on preferences set during install. – Sean Allred Jan 20 '15 at 5:01
  • If not specified, latex uses a predefined papersize which is stored in some config file during installation. Please check if there is a difference, on using letter and one a4. – Johannes_B Jan 21 '15 at 14:59
  • MikteX sets default paper size in the Options Menu, General tab. – Steven B. Segletes Jan 21 '15 at 15:00
  • Thank you all. I checked the tex file, it is exactly the same. Then, I added \listfiles, and found there is a different packages version. The right one is :url.sty 2006/04/12 ver 3.3 Verb mode for urls, etc. The wrong one is :url.sty 2013/09/16 ver 3.4 Verb mode for urls, etc. Does this make sense?\\ I also find an interesting phenomenon, although the top page margin is different, the total pages are the same, and the content on each page is also exactly the same. The difference is just the top and left margin a little bigger making it look weird. Could you figure out what's the reason?Thanks. – Charles Jan 22 '15 at 2:38
0

Thanks for helping me. Problems have been solved. I just changed the default page size A4(A4 size) to Letter, then backed to the default page size A4(A4 size). It was weird, wasn't it? As I didn't change any other things, just back to the default. Any way, problems have been solved, so I write it down here, which may be helpful to the ones who meet the same problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.