5

For many years I used the package betababel to combine Latin and Greek letters in one document, but since version 2014.20141024-1 of texlive-lang-greek, the simple example

\documentclass{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{betababel}

\begin{document}
\bcode{lo/gos}
\end{document}

(which worked with the previous version) produces this error when compiling with pdflatex:

Package babel Error: You haven't defined the language polutonikogreek yet.

Any ideas how to solve this?

  • Welcome to TeX.SX! Nice question and thanks for the MWE. Maybe, you send a notice to the maintainer of betababel. – LaRiFaRi Jan 20 '15 at 12:32
4

I do not know if this runs into some clashes, but as betababel loads babel as well, it should be safe to do:

% arara: pdflatex

\documentclass{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[polutonikogreek, ngerman]{babel}
\usepackage[ngerman]{betababel}

\begin{document}
    \bcode{lo/gos}
\end{document}

As written in your output, the babel option polutonikogreek was missing. As betababel does not offer this option, just load it via the original babel.

enter image description here

  • The manual for betababel says explicitly not to do this. – cfr Oct 31 '16 at 16:28
  • @cfr I fear the betababel documentation is outdated: betababel was last updated 2005, while babel-greek and the babel kernel were last updated 2016. – erreka Oct 31 '16 at 19:11
  • @wicho The problem is that betababel wants to load Babel with options. If you load Babel first, that isn't possible. – cfr Oct 31 '16 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.