0

When parsing in XeLaTeX the template available in SIGCHI with the package csvsimple and "fontspec" (to include special UTF8 accent characters), I'm able to see "áéíóú" in the body of the document but not in the titles of the sections or in references.

For instance: "Detección" is displayed as "Deteccin". Is there a way to conserve csvsimple and have the accented characters at the same time?

PD: I also used \usepackage[utf8]{inputenc} with pdflatex but that is not compatible with csvsimple.

Adding the MWE that works in XeLaTeX:

\documentclass[spanish]{sigchi}
\usepackage{balance}  % to better equalize the last page
\usepackage{graphics} % for EPS, load graphicx instead
\usepackage{times}    % comment if you want LaTeX's default font
\usepackage{url}      % llt: nicely formatted URLs
\makeatletter
\def\url@leostyle{%
  \@ifundefined{selectfont}{\def\UrlFont{\sf}}{\def\UrlFont{\small\bf\ttfamily}}}
\makeatother
\urlstyle{leo}
\def\pprw{8.5in}
\def\pprh{11in}
\special{papersize=\pprw,\pprh}
\setlength{\paperwidth}{\pprw}
\setlength{\paperheight}{\pprh}
\setlength{\pdfpagewidth}{\pprw}
\setlength{\pdfpageheight}{\pprh}
\usepackage[]{hyperref}
\hypersetup{
pdftitle={SIGCHI Conference Proceedings Format},
pdfauthor={LaTeX},
pdfkeywords={SIGCHI, proceedings, archival format},
bookmarksnumbered,
pdfstartview={FitH},
colorlinks,
citecolor=black,
filecolor=black,
linkcolor=black,
urlcolor=black,
breaklinks=true,
}
\newcommand\tabhead[1]{\small\textbf{#1}}
\usepackage{csvsimple}
\usepackage{fontspec}

\begin{document}
\section{Acústica}
Acústica
\end{document}

The result is: La Acstica (as the section title, notice that there is no ú) Acústica (in the body)

9
  • Could you, please, provide a compilable MWE to help us to understand the problem? Currently, I cannot see how csvsimple interferes with accents in section titles. – Thomas F. Sturm Jan 23 '15 at 8:21
  • csvsimple is compatible with \usepackage[utf8]{inputenc}. There could be problems with files containing the UTF-8 BOM. This can be easily solved by tex.stackexchange.com/questions/209853/… – Thomas F. Sturm Jan 23 '15 at 8:24
  • I added the MWE, thanks for any help! I tried also using \usepackage[utf8]{inputenc} and \DeclareUnicodeCharacter{FEFF}{}, but later got "Unicode char \u8:χ not set up for use with LaTeX" – JFonseca Jan 23 '15 at 14:57
  • The problem has nothing to do with csvsimple as far as I can see. The class sigchi seems to use a font for the sections which does not contain the accents (?)... – Thomas F. Sturm Jan 23 '15 at 15:25
  • 1
    It makes little sense using XeLaTeX along with \usepackage{times}. Use pdflatex (and \usepackage{mathptmx}), with \usepackage[utf8]{inputenc}. – egreg Jan 23 '15 at 22:53
1

Ok, I think I located the problem: I had some special characters in jabref and in the CSV file. I was loading a .bib file with some Chinese non utf-8 characters and in the CSV I was using 'ó' in the headers. After removing them, the problems were solved.

This combination worked for me:

  • SIGCHI template
  • \usepackage[utf8]{inputenc}
  • \usepackage{csvsimple}
  • PdfTeX

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.