5

I'm trying to use xy-pic to do commutative diagrams but the symbols above my arrows keep coming up in the wrong places!

Can anyone see what I am doing wrong? Many thanks.

\[ \xymatrix{\Gamma(\xi) \ar[r]^\nabla \ar[d]^{g^*} & \Om^1(M) \otimes \Gamma(\xi) \ar[d]^{g^*} \\
          \Gamma(g^*\xi) \ar[r]^{g^*\nabla} & \Om^1(M') \otimes \Gamma(g^*\xi)} \]

This is how it looks

EDIT: An interesting point is that, whenever I extend my diagram like this

\[ \xymatrix{\Gamma(\xi) \ar[r]^\nabla \ar[d]^{g^*} & \Om^1(M) \otimes \Gamma(\xi) \ar[d]^{g^*} \ar[r]^{\tilde{\nabla}} & \Om^2(M) \otimes \Gamma(\xi)  \ar[d]^{g^*} \\
          \Gamma(g^*\xi) \ar[r]^{g^*\nabla}       & \Om^1(M') \otimes \Gamma(g^*\xi) \ar[r]^{g^*\tilde{\nabla}}       &  \Om^2(M') \otimes \Gamma(g^*\xi)} \]

The symbols on the right hand side come out fine!

enter image description here

1 Answer 1

5

The label is placed, by default, midway from the column centers; in cases like these, you can choose to place it at the center of the arrow with \ar[r]^-\nabla:

\documentclass{article}
\usepackage[all,cmtip]{xy}
\begin{document}
\[
\xymatrix{
  \Gamma(\xi) \ar[r]^-\nabla \ar[d]^{g^*} & \Omega^1(M) \otimes \Gamma(\xi) \ar[d]^{g^*} \\
  \Gamma(g^*\xi) \ar[r]^-{g^*\nabla} & \Omega^1(M') \otimes \Gamma(g^*\xi)
}
\]
\end{document}

enter image description here

A possible improvement is adding some width to the space between columns:

\xymatrix@C+2em{
  \Gamma(\xi) \ar[r]^-\nabla \ar[d]^{g^*} & \Omega^1(M) \otimes \Gamma(\xi) \ar[d]^{g^*} \\
  \Gamma(g^*\xi) \ar[r]^-{g^*\nabla} & \Omega^1(M') \otimes \Gamma(g^*\xi)
}

will produce

enter image description here

I recommend the cmtip option, as the default arrow tips are quite awful.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .