3

It seems I am having version issues with BibLaTeX/Biber. When I run Biber, I get

biber datei
INFO - This is Biber 1.8
INFO - Logfile is 'datei.blg'
INFO - Reading 'datei.bcf'
WARN - Warning: Found biblatex control file version 2.6, expected version 2.5

After next PDFLaTeX-Lauf run I get

File 'datei.bbl' is wrong format version - expected 2.4

I use

\usepackage[style=alphabetic]{biblatex}
\bibliography{bibliothek}

in the preamble.

Am I doing something wrong here or does this boil down to the version problem? If yes, which component would I have to up- or downgrade? How do I do this using tlmgr or apt-get?

I should mention that the citations in the PDF are displayed as if in debug mode.

Thanks...

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. I would start by removing generated files from your working directory, especially the .bcf and .bbl. Then try recompiling. If you still have problems, we need more information: which TeX distribution are you using? Is it up to date? etc. – cfr Jan 25 '15 at 15:47
  • Thanks, I did remove those aux-files and the error remains. I also use \usepackage[style=alphabetic,backend=biber]{biblatex} \bibliography{bibliothek} now, but that did not help. – Horst S Jan 25 '15 at 15:51
  • Sorry, was on the wrong pdf file. The PDF document looks fine now, as expected. Deleting the "keywords" from my .bib file helped, so did specifying the backend. Yet, the version warnings remain. – Horst S Jan 25 '15 at 16:06
  • Did you install tex-live from the mint repos with your package manager? If yes i would recommend to delete your installation and download install texlive from the official page: tug.org/texlive/acquire-netinstall.html – MaxNoe Jan 25 '15 at 16:07
  • 3
    The packages in the distribution's package managers are often out-of date and tex-live is splitted into a jungle of subpackages. TexLive has it's own packagemanager, tlmgr, with which you can keep your packages up to date. – MaxNoe Jan 25 '15 at 16:10
2

Your problem is not a downgrade, you should do an upgrade.

The current version of biber (you should use) is 1.9, the corresponding version of package biblatex is 2.9a for my MiKTeX system. It is important to use the current version of biblatex to support the possibilities of biber.

To get no bad surprises with biber just keep your system up to date ...

TeX Live and MiKTeX have different mechanism to keep the distribution up to date. Search for update manager or package manager in the documentation or here on this side.

1

Had same problem logged in TeXstudio.

1) Fixed it with portable version. It has usually lower version and all of the packages are included.

To downgrade biber (my ex.) from 2.6 to 2.5 copy \texmfs\install\miktex\bin\biber.exe to MiKTeX 2.9\miktex\bin\x64\biber.exe

2) Also you may get previous versions of biber from cite: https://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/

3) You can also check official biber page https://sourceforge.net/projects/biblatex-biber/ to check out versions capabbility and probably update biblatex further from official site: https://sourceforge.net/projects/biblatex/files/?source=navbar Pay attention to the readme file in distribution. I contains installation instructions.

  • Sorry for 3rd link - don't haveenough reputatuion to paste it normally. – Globber Sep 25 '16 at 8:22
0

I have MikTeX 2.9 installed on Windows 10. All packages are updated (in Admin as well as in User mode). When I tried to used Biber I got an error message:

INFO - This is Biber 2.7
INFO - Logfile is 'main.blg'
INFO - Reading 'main.bcf'
ERROR - Error: Found biblatex control file version 2.9, expected version 3.3.
        This means that your biber (2.7) and biblatex () versions are incompatible.
        See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

In package manager the following versions were shown:

  • 2.7 for miktex-biber-bin-x64
  • 3.7 for biblatex

Reinstallation of these packages did not solve the problem.

I checked which biblatex file is used in the system with the following command (open cmd window and simply type this)

kpsewhich biblatex.sty

The output was:

C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/biblatex.sty

Folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/ is basically used to install packages installed "on the fly".

I searched if there are other files biblatex.sty in the system and it turned out that the second copy was stored in the MikTeX installation folder:

c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\

I am not sure what it means. Is it that my MikTeX installation is corrupted or I have double installation of biblatex nor what is the reason for all this.

I made a simple test. I change the folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/ name to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex_old/

and copy the whole folder from c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\ to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/

Next I cleared all generated files in my tex project folder (it is important) i.e. delete *.aux, delete *.bcf, ... etc. and recompiled the project again with pdflatex, next biber, next pdflatex

It works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.