7

I'm trying to create a glossary using TexMaker on Mac OS X. TexMaker does not provide an entry called 'makeglossary' or the like in Preferences > Quick Build > Wizard. My build settings in the Wizard are as follows:

PdfLaTeX Bibtex PdfLaTeX PdfLaTeX Pdf Viewer

I have tried to add the make glossary function manually by adding 'makeglossaries %.tex' after the Bibtex command in the user syntax, i.e.

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|"/usr/texbin/bibtex" %.aux| makeglossaries %.tex | "/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex|open %.pdf

However, when I try to compile my file, I get an error message saying

Error : could not start the command : makeglossaries "filename".tex

Here is my MWE as well as the contents of my gloss.tex and bib.bib file:

MWE:

\documentclass[a4paper,11pt,oneside,fleqn]{scrbook}
\usepackage[ngerman,english]{babel} % language listed last is default setting
\usepackage[utf8x]{inputenc}

\usepackage{hyperref}


\usepackage[acronym,toc]{glossaries}
\makeglossaries
\loadglsentries{gloss}

\usepackage[square,numbers]{natbib}
\addto\captionsenglish{\renewcommand{\bibname}{References}}


\begin{document}

\frontmatter

\tableofcontents

\clearpage
\glsaddall
\printglossary[type=\acronymtype]  
\printglossary


\mainmatter

\gls{a} \gls{b}

\backmatter

\bibliography{bib}
\bibliographystyle{plainnat}
\nocite{*}


\end{document}

gloss.tex file:

\newglossaryentry{a}
{
        name=A,
        description={text}
}


\newacronym{b}{B}{text}

bib.bib file:

%bib.bib
@book{Robinson2011,
    author = {Matthew Robinson},
    title = {Symmetry and the Standard Model - Mathematics and Particle Physics},
    publisher = {Springer},
    year = {2011},
}

Thank you for your help.

Best Regards, Sebastian

4
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – texenthusiast Jan 28 '15 at 2:33
  • I tried that, now I'm getting an error saying: Error : could not start the command : make glossaries "filename" – Sebastian_92 Jan 28 '15 at 2:50
  • I have also tried the approach suggested in the link you provided, but I still get the same error message. Is there a specific order if I would like to use Bibtex, Makeindex and makeglossaries simultaneously? – Sebastian_92 Jan 28 '15 at 3:04
  • may be try "/usr/texbin/makeglossaries" % . this type of automation of compiling bibtex makeglossaries etc.. can be done using arara and latexmk tex.stackexchange.com/questions/64/… – texenthusiast Jan 28 '15 at 3:05
5

The exact solution to this requires complete knowledge of your operating system and setup. But in general, TeXmaker depends upon the environment path variable, except for the programs loaded into options.

So there are two possible solutions.

1) You can add the path to the latex binaries to the systems environmental path variable.

2) Or you can use the absolute path to the glossaries path in your command in quickbuild by editing the command you added to: "/usr/texbin/makeglossaries" %

There is more information on this issues especially if you use multiple glossaries in printglossaries, makeglossaries: (0 entries accepted, 0 rejected)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.