2

I've got many troubles with raster images and beamer class:

  1. convert *.png to eps, cslatex => dvips => ps2pdf, images look like compressed by jpg algorithm :/
  2. convert *.png -> eps -> pdf (epstopdf) - images after conversion look like compressed again...
  3. use *.png and pdfcslatex - images are ok, however positioning, etc. doesn't work good...
  4. use cslatex => dvipdfm - doesn't work with beamerclass...

Without beamer, I'm using the 4th option with eps images and everything's ok... Beamer is really a great package, however these troubles with images are * * * * *

What am I doing wrong? Is there any other possibility?

solved

5
  • 1
    What is the original format of your images? PNG? If you are using PNG, you just need to use pdflatex. Jul 7, 2011 at 14:11
  • Note that this has nothing to do with the beamer class in particular. Images aren't included any different with it than any other LaTeX documents (Maybe you might know LaTeX only from beamer?). I would recommend you as well to use pdflatex and PNG images directly. Jul 7, 2011 at 14:17
  • mics - some of them are png, others eps. Thus, I wanted to convert all of them to eps... Well, pdflatex is not the best options, due to strange spacing, centering, etc...
    – morph
    Jul 7, 2011 at 14:30
  • I probably find the problem with centering - I was using bb with pdf, and thus, it couldn't work. Ok, I hope, it's allright now
    – morph
    Jul 7, 2011 at 15:50
  • pdflatex shouldn't behave different for spacing, centering, etc. You are right that bb could caused problems with PDF images. There is no need to use this with pdflatex. Jul 7, 2011 at 18:15

1 Answer 1

3

It seems that the biggest mistake I made was using of bb (I forgot to remove when I changed from png to pdf) with pdf images. So, I am using pdflatex and it works now. Sorry for silly question...

1
  • Thanks for letting us know what the issue was. With pdflatex you don't need bb for PDF, PNG or JPG images. It can read the bounding box information directly from the files. Please accept this answer after the required waiting period (48 hours I think) so that the question is officially concluded. Thanks. Jul 8, 2011 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .