7

I have recently joined the mac club and I am having trouble using pdflatex. I have installed MacTex which should have everything included but when trying to run typeset I receive the error

'/usr/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://www.tug.org/mactex/ and follow the instructions to (re)install MacTeX. A less likely possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the macports or fink distributions.'

I have searched for pdflatex and could not find it anywhere...can anyone help me? I have read other forums which say reinstalling MacTex doesn't work and I also did this and it made no difference.

Extra info:

OS 10.10.1 Yosemite I have reasonable experience using linux / terminal

closed as unclear what you're asking by Sean Allred, Maarten Dhondt, user31729, egreg, darthbith Jul 8 '15 at 20:57

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX-sx! Did you try the 'fix MacTeX' utility from the MacTeX site? – Joseph Wright Jan 28 '15 at 15:51
  • For some reason texbin is a file, not a folder?? I guess that could be the problem? – UpperEastSide Jan 28 '15 at 17:14
  • @MichaelHemming It should be a link. For example, ls -l /usr gives me lrwxr-xr-x 1 root wheel 63 6 Jun 2014 texbin -> /Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin – Joseph Wright Jan 28 '15 at 17:17
  • Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. – Martin Schröder May 9 '15 at 19:45
7

I think I figured it out.

Go into your terminal and type in: which pdftex

You should get some sort of directory where your latex is installed. like: /opt/local/bin/pdftex

What you should do now is to change the directory where TexShop looks.

Do this by going into Preferences > Engine: and changing the path settings to the directory that which pdftex gave out.

I put /opt/local/bin/ and it worked out for me.

Looking around on the internet tells me that this is a macports problem. So you have to change it manually.

  • Ah, macports. Everyone's favorite package manager to hate on :) It's generally advised to not deal with TeX stuff using package managers -- the interdependencies are too complicated for a large-scale manager to really do well. (Aside, homebrew > macports ;).) – Sean Allred Jul 8 '15 at 20:31
  • This didn't work for me, I typed 'which pdftex' into terminal and got no output. – Omar Haque Feb 9 '16 at 14:26
  • which pdflatex returns nothing! – Mona Jalal Sep 12 '17 at 2:40
  • Then LaTeX is probably not installed correctly. – user2047437 Nov 29 '17 at 14:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.