0

This question already has an answer here:

In my .bib file, there is a reference including the following name in the authors list:

Mitášová, Helena

When the PDF is generated, this name does not display correctly:

MitÃaÅaovÃa

I searched for related topics, and found the following link:

[How can some eastern European diacritics be correctly displayed with the Alegreya font and pdftex?

I tried including the package Alegreya mentioned therein, but still the problem persists.

Can someone tell me if there is a package which I can use to get all the unicode text (I am presuming that this will take care of Eastern European names as well, or please correct me if I am wrong) displayed correctly in the output?

TIA

I tried adding \usepackage[utf8]{inputenc} but get a inputenc Error: Unicode char \u8” for the equation $\mu = 4\pi \times 10^{-7}$. I tried using \usepackage[utf8x]{inputenc} instead based on search, but that shows a different error not seen before.

If I remove both the packages, the PDF document is generated as before, so I am not sure whether utf8 package is the way forward for me as I do not wish to spend a lot of time debugging latex issues....unless someone can tell me a one time fix to make all the issues go away associated only with the introduction of the utf8 package, or may be suggest an alternate package which could display all the European names correctly.

marked as duplicate by Mico, user13907, Paul Gessler, Jesse, musarithmia Jan 29 '15 at 3:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Try adding \usepackage[utf8]{inputenc} to your preamble. – user11232 Jan 29 '15 at 0:49
  • 1
    Probably you should save your .bib file in UTF8 format, and use biblatex/biber. Biber understands utf8, and bibtex does not. – Bernard Jan 29 '15 at 0:51
  • I have edited my question.....please take a look – Vinod Jan 29 '15 at 1:20
  • Did you make sure that the document is saved in the right encoding? – cfr Jan 29 '15 at 1:29
2

Even though pdfLaTeX (with the right input encoding settings) can process utf8-encoded letters correctly, BibTeX can not, i.e., it chokes on characters such as á and š. You therefore have to change the way the accented characters are coded.

author = {Mit{\'a}{\v s}ov{\'a}, Helena}

BibTeX (not LaTeX) will "read" this as "Mitasova" -- note: no accented characters -- and sort the entry accordingly when it constructs the .bbl file. Later, when LaTeX processes the contents of the .bbl file, the accented characters will show up once more.

  • 1
    Better still, write author = {Mit{\'a}{\v s}ov{\'a}, Helena}, for inclusion in a .bib file. Doing so will assist with BibTeX's diacritic-purging step, by the end of which BibTeX should have "Mitasova", for the purpose of sorting entries by authors' surnames. – Mico Jan 29 '15 at 2:25
  • @Mico I edited the answer to reflect your observation – Ludenticus Jan 29 '15 at 13:21
  • 1
    I've taken the liberty of editing your answer a bit more. :-) – Mico Jan 29 '15 at 13:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.