1

As you might know there is a bug in the appendix package which prevents hyperref from linking to the appendices, e.g. here. The aforementioned article says this is bug is triggered when babel is used and is suggest some tricks to circumvent it.

I use xepersian, which I do not think uses babel, and those tricks do not work for me. Do you have any suggestions? Here is my MWE:

\documentclass[10pt,a4paper]{report}
\usepackage[titletoc,toc,page]{appendix}
\usepackage[backref,bookmarks]{hyperref}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{xepersian} 
\settextfont{FreeFarsi}% http://sourceforge.net/projects/fpf/
\DefaultMathsDigits
\renewcommand\appendixtocname{پیوست‌ها}
\renewcommand\appendixpagename{پیوست‌ها}
\begin{document}
\tableofcontents
\chapter{\LR{Preface}}
\begin{appendices}
\chapter{\LR{APPA}}
\chapter{\LR{APPB}}
\end{appendices}
\end{document}
  • Is the issue, only the `linking to the appendices'? – Aditya Jan 31 '15 at 12:41
  • 1
    v15.9 of xepersian is now on CTAN which fixes the problem. – Aditya Jan 31 '15 at 17:05
  • 1
    I couldn't find a mirror that hosts v15.9 (they all seem to have v15.8). As soon as they get synced, I'll try it and report back. – Eliad Feb 1 '15 at 2:09
  • Now there is a link, but it is to the wrong page. – Eliad Feb 1 '15 at 20:53
  • I tried the example and it seems to work correctly. Can you confirm? – egreg May 2 '15 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.