I have come across an ancient (1995) LaTeX file which was (surely) once compliant, but now does not compile at all. Is there any way to rescue it?

My actual question is much more precise. I want a copy of the follow paper on the arXiv:


Downloading the pdf source produces something which looks like a document on a4 paper printed on US letter (the bottoms of some pages are cut off). However, if you download the TeX source from the arXiv, then it doesn't compile (even adding .tex, naturally). I'm using an up to date version of TeXshop on a mac.

  • 1
    Welcome to TeX.SX! The file is made for AMS-TeX, you should compile it with amstex. Or uncomment the \input amstex line and compile with pdftex.
    – egreg
    Commented Jan 31, 2015 at 21:56
  • 3
    The page you reference says : 13 pages in AMS-TeX v2.1 so it is not latex it is amstex which is a different format plain pdftex should work, so long as you have amstex.tex on your system Commented Jan 31, 2015 at 21:56
  • 1
    I changed the title so other people with \input amstex in their file can find this one
    – egreg
    Commented Jan 31, 2015 at 22:10

3 Answers 3


It's not LaTeX 2.09, but AMS-TeX, a completely different format.

After having added the .tex extension, open your file with TeXShop and uncomment the \input amstex line

%Paper: alg-geom/9401005
%From: "E. Looijenga" <[email protected]>
%Date: Mon, 24 Jan 1994 16:34:09 +0100
%Date (revised): Fri, 24 Mar 1995 16:06:18 +0100

\input amstex
\define\Z{{\Bbb Z}}
\define\R{{\Bbb R}}
\define\Q{{\Bbb Q}}

Then choose the “Plain TeX” engine from the drop down menu next to the “Typeset” button, like in the following picture

enter image description here

Press the “Typeset” button. Et voilà. ;-)

enter image description here

If you know how to use the Terminal, then

amstex -output-format=pdf 9401005v2

will produce a PDF file.


This was brought to my attention recently.

The v2 of the code seems to be coded for an A4DIN page size, but on the main arxiv.org website, we force all submissions into letterpaper as part of the dvi -> ps -> pdf processing.

I've updated the source files for this paper on arXiv adding the line:


which moves the text on the page "up", so there is now no information loss on the printed pdf.


Jake Weiskoff

Senior arXiv admin


user egreg pointed out this was an amstex file (when a *.tex file doesn't compile with latex, I use the other options that TeXshop gives (PlainTeX), but now I see that amstex file.tex from the command line also works.

The other latex issue (with the margins) was resolved when I removed the line


from the file.

  • oops, I see egreg gave an answer as well, this wasn't necessary....
    – user71525
    Commented Jan 31, 2015 at 22:07
  • I've flagged this but you should, I think, be able to delete the answer yourself if you wish to. (I think you can always delete your own answers, but I'm not certain which is why I've flagged it in case you don't have sufficient reputation yet.)
    – cfr
    Commented Jan 31, 2015 at 22:17
  • Feel free to delete it if you want, but it is not really neccessary. Commented Feb 5, 2015 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .