3

I saw some questions about "double subscript" but I have a weird situation. I have the following parts in my code:

line 44-48

and...

line 56-59

I have used almost the same subscripts in both of them, but the latter one gives a "double subscript" error while the first one works fine. What am I missing there? What is the reason for that error?

Here is my error bar:

error bar

5
  • 1
    Welcome to TeX.SX! You have h_{j)}_0 that qualifies as double subscript.
    – egreg
    Commented Jan 31, 2015 at 23:23
  • Do you wish h_{j_0}?
    – Sigur
    Commented Jan 31, 2015 at 23:29
  • 1
    Replace h_{j)}_0 with {h_{j)}}_0. The structure a_b_c is causing the error. Add brackets.
    – anderstood
    Commented Jan 31, 2015 at 23:49
  • 1
    Thank you all for your answers. The problem was really about braces. I did exactly what @anderstood said and it pefectly worked!
    – sahin
    Commented Feb 1, 2015 at 8:18
  • @anderstood -- your comment contains the answer to the question. please make it into an actual answer so that this doesn't have to be chased down in the "answer the unanswered" session next saturday. Commented Feb 2, 2015 at 2:45

1 Answer 1

5

The error is caused by the improper double subscript h_{j)}_0 (of type a_b_c). Add brackets to help latex discriminate between a_{b_c} or {a_b}_c.

enter image description here

Note that is similar to the ambiguity in maths: is 2^3^4 supposed to mean 8^4 or 2^81?

1
  • 1
    i think you are expecting the formulas to be rendered as they are on the math forum -- where mathjax is used. mathjax is not used in tex.sx, since it is usually the case that people here want to see the source, not the output. output has to be inserted as a (png) image. Commented Feb 2, 2015 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .