1

I am trying to build a CV with friggeri but I am trying to change the default font 'Helvetica Neue' with 'Source Sans Pro'.

This means that I want to change:

\newfontfamily\bodyfont[]{Helvetica Neue}
\newfontfamily\thinfont[]{Helvetica Neue UltraLight}
\newfontfamily\headingfont[]{Helvetica Neue Condensed Bold}

\defaultfontfeatures{Mapping=tex-text}
\setmainfont[Mapping=tex-text, Color=textcolor]{Helvetica Neue Light}

to

\newfontfamily\bodyfont[]{Source SansPro}
\newfontfamily\thinfont[]{Source Sans Pro ExtraLight}
\newfontfamily\headingfont[]{Source Sans Pro Black}

\defaultfontfeatures{Mapping=tex-text}

\setmainfont[Mapping=tex-text, Color=textcolor]{Source Sans Pro Light}

in the frigerri-cv.cls file.

So I checked if I had 'Source Sans Pro' installed.

locate sourcesanspro returns all the otf files in the folder: /usr/share/texlive/texmf-dist/fonts/vf/adobe/sourcesanspro/ and the sty file /usr/share/texlive/texmf-dist/tex/latex/sourcesanspro/sourcesanspro.sty

Seeing this I thought I will be fine, but...

I import in the package:

 \RequirePackage[default]{sourcesanspro}

And then I try to use it:

 \newfontfamily\bodyfont[]{Source Sans Pro}

But this fails.

fontspec error: "font-not-found"
! 
! The font "Source Sans Pro" cannot be found.

I also tried \setsansfont{Source Sans Pro} as in examples I have seen online but that also fails.

I tried running fc-list to check if the font is there, but it is not. Could this be the issue? What would you advise me to do? I am particularly puzzled because the \RequirePackage command succeeds, so the package is there.

Thanks!

2
  • don't change the original class files, just redefine things in your preamble, or save a copy of the class under a different name (otherwise your changes are likely to be lost when the system updates) It is quite common to have the latex source files but not the fonts, which are almost always distributed separately. Commented Feb 1, 2015 at 14:30
  • @DavidCarlisle thanks for the advice. The fonts should be there as I used sudo apt-get install texlive sudo apt-get install texlive-fonts-recommended texlive-fonts-extra to install them.
    – elaRosca
    Commented Feb 1, 2015 at 14:41

2 Answers 2

3

I have fixed the issue as follows:

installed the font globally by following the instructions here (note the wget link does not work anymore, so I installed from github).

After that I could see the font in 'fc-list' and I fixed the imports (the name was also written wrong).

\newfontfamily\bodyfont[]{Source Code Pro}
\newfontfamily\thinfont[]{Source Code Pro ExtraLight}
\newfontfamily\headingfont[]{Source Code Pro Black}
% %
\defaultfontfeatures{Mapping=tex-text}
\setmainfont[Mapping=tex-text, Color=textcolor]{Source Code Pro Light}

As @DavidCarlisle suggested I use these imports in my tex file instead of their cls.

0

In my case, re-downloading the fonts from Adobe was not necessary, as they just need to be copied into the system font directory.

After installing the Texlive packages, the font files were installed to the directory /usr/share/texlive/texmf-dist/fonts/opentype/adobe/sourcesanspro/, but this did not make them visible to the OS. My solution, for Debian, was to copy the fonts into the system font directory.

cp -v /usr/share/texlive/texmf-dist/fonts/opentype/adobe/sourcesanspro/*.otf /usr/local/share/fonts

And then rebuild the font list

fc-cache -f

Now the Source Sans Pro fonts and were able to be used by \setmainfont in xelatex. However, I still do not see the fonts in fc-list, but they are usable now. I did not need to change the name to 'Source Code Pro', 'Source Sans Pro' now works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .