1

I have an encoding file with some tex encoding, I have to use the ligature and kerning instruction for the encoding to make a replacement two char into a single ligature. It looks like the following:

% LIGKERN parenleft parenright =: comma ;

All the three chars (parenleft, parenright, comma) are presented in the encoding. I try to replace the tex code (.tex):

()

But when I run the compilation procedure, and then try viewing the resulted (I use pdflatex) PDF.

Non-PDF special ignored!] (./hello1.aux) ){/usr/share/texmf-texlive/fonts/enc/d
vips/hiptex/orthucs8.enc}<</usr/share/texmf-texlive/fonts/type1/hiptex/irmucs.p
fb>>

I see that the encoding is picked up, but in PDF I see just the two parens separated as (), and not the comma ..

Update: I've found out that the ligatures can be setup in .enc, and applied to .tfm/.vpl files during generation them from .afm. So then i've added a line into .enc file:

% LIGKERN parenleft parenright =: comma ;
% LIGKERN quoteleft parenleft =: comma ; 

And tried to make a .vpl from .afm, getting the following code in .vpl:

(LABEL O 50) (comment parenleft)                                     
(LIG O 51 O 54)

I'm seeing the only single ligature parenleft parenright -> comma, and there is no ligature quoteleft parenleft -> comma. That is strange. Why the afm2tfm refuses to generate all the ligatures?

9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.