0

I have the following in my preamble:

\usepackage[notes,natbib,backend=biber,idemtracker=context,ibidtracker=context]{biblatex-chicago}

This should, in the first instance of a citation (in this case, an article), output something like:

Joshua I. Weinstein, “The Market in Plato’s Republic,” Classical Philology 104 (2009): 440.

(that's taken from the Chicago Manual's own website)

Instead, what I see in the document output by xelatex is something like this:

Weinstein ("The Market in Plato's Republic")

This is definitively wrong, and I can't figure out what format that's supposed to be (natbib?). This started happening after the texlive update last October (2014), and has persisted ever since.

I am using lyx. Any advice?

Thanks,

EE

EDIT: MWE follows. Notice, the citation in the footnote is formatted incorrectly: It should appear exactly as it does in the bibliography.

%% LyX 2.1.2 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[12pt,american]{scrartcl}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text,Numbers=OldStyle]{Linux Libertine}
\setsansfont[Mapping=tex-text]{Linux Biolinum}
\usepackage[a4paper]{geometry}
\geometry{verbose,tmargin=2cm,bmargin=2cm,lmargin=2.25cm,rmargin=3.25cm}
\usepackage{fancyhdr}
\pagestyle{fancy}
\setcounter{tocdepth}{1}
\setlength{\parskip}{\smallskipamount}
\setlength{\parindent}{0pt}

\makeatletter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\setkomafont{sectioning}{\rmfamily \bfseries}
\KOMAoptions{headings=small}
\usepackage{fontspec}
\usepackage{xunicode}
\defaultfontfeatures{Mapping=tex-text}
\usepackage[notes,natbib,backend=biber,idemtracker=context,ibidtracker=context]{biblatex-chicago}
\addbibresource{/home/$USER/carrier5/music/intonation-book/bookbib.bib}
\setmainfont[Ligatures={Historic,Rare,Discretionary,TeX},Contextuals=Swash]{Linux Libertine}
\newfontfamily\latinfont[Script=Latin,Ligatures={Historic,Rare,Discretionary,TeX},Contextuals=Swash,Alternate=0,Style=Historic]{Linux Libertine}
\newfontfamily\italianfont[Ligatures={Historic,Rare,Discretionary,TeX},Contextuals=Swash,Alternate=0,Style=Historic]{Linux Libertine}
\errorcontextlines=10

\makeatother

\usepackage{xunicode}
\usepackage{polyglossia}
\setdefaultlanguage[variant=american]{english}
\begin{document}
here is some text%
\footnote{See \citet{adams1993effects}.%
}



\printbibliography
\end{document}

(note: $USER is a placeholder for my real username)

Biber does not throw any errors. No, I cannot compile any documents with biblatex files such that they properly follow Chicago style.

Here is how that entry looks in my .bib file (the one named bookbib.bib):

@Article{adams1993effects,
  Author         = {Adams, B.J. and Fields, L. and Verhave, T.},
  Title          = {Effects of test order on intersubject variability
                   during equivalence class formation.},
  Journal        = {The Psychological Record},
  publisher      = {Kenyon Coll Psychology Dept},
  year           = 1993
}

I'm using Lyx, which adds in its own modules and then applies modules listed in the preamble; this is likely the reason for the doubled module entries. I'll reply to the citation commands in the answer thread below, as I can't see them while editing =/

5
  • Without a complete MWE there is really not a lot we can do from here. Did you make sure that Biber ran successfully? What do the logs say - especially the .blg file? Can you compile other biblatex documents to your satisfaction?
    – moewe
    Feb 5 '15 at 2:27
  • MWE added above
    – user242047
    Feb 7 '15 at 8:00
  • Could you also add an example BibTeX database entry?
    – Joseph Wright
    Feb 7 '15 at 8:19
  • Note that you note certain packages multiple times. You MWE does not compile on my machine. If you however use \footcite[See][]{wilde} instead of \footnote{See \citet{wilde}.}, you will see something quite close to your taste. If you insist on this construction, try \footnote{See \cite{wilde}.} (Note that this is \cite not \citet!)
    – moewe
    Feb 7 '15 at 8:23
  • this MWE will not compile without the .bib file that it includes. Editing the example above to add that entry from the .bib file.
    – user242047
    Feb 7 '15 at 14:58
1

Here is a working MWE that demonstrates correct usage of biblatex-chicago. See if you can adapt this to your own setup and if it still works for you.

\documentclass{article}
\usepackage{filecontents} % for example
\begin{filecontents}{usermwe.bib}
@Article{Weinstein:MarketPlato,
  author=       {Weinstein, Joshua I.},
  title=        {The Market in Plato's Republic},
  journaltitle= {Classical Philology},
  volume=       104,
  year=         2009,
  pages=        440,
}
\end{filecontents}
% But note that the pages should be the complete page range.

\usepackage[notes,backend=biber]{biblatex-chicago}
\addbibresource{usermwe.bib}

\begin{document}

There is an interesting article about Plato and the market.%
    \autocite[440]{Weinstein:MarketPlato}

\printbibliography

\end{document}

enter image description here enter image description here

5
  • I manually added an \autocite[]{} entry using a tag from my .bib file, following this format. It formats correctly, following chicago style. Now: how do I get Lyx to use \autocite instead of \cite or \citet for citations?
    – user242047
    Feb 7 '15 at 15:19
  • BOOM. This tip was the one that got me what I need: adding \renewcommand\citet{\autocite} right below the biblatex-chicago entry forced Lyx to replace its default \citet with \autocite, which correctly results in Chicago-style citations. THANK YOU. This has been driving me nuts for months.
    – user242047
    Feb 7 '15 at 15:28
  • PLOT TWIST: no, it actually didn't fix the problem entirely. Turns out, when the author field is formatted {family, given}, it will format the citation correctly, but when the field is formatted {given family} it goes back to natbib style. Why would it do this? The two are supposed to be equivalent. After updating texlive again, I'm back to it not using Chicago style entries.
    – user242047
    Jun 10 '20 at 18:29
  • @user242047 I believe biblatex-chicago expects family, given format. I didn't know there was any other option. Jun 11 '20 at 14:46
  • Well, I might go back through and reformat the ones that would need that (and use brackets to protect the ones that are natively family-name-first), but my issue here turned out to be something else: I needed to add another \renewcommand to replace \textcite with \autocite as well, and now all citations are properly formatted.
    – user242047
    Jun 12 '20 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.