10

I need to insert an at symbol, @ , which I know how to do in text, but can't figure out how to do in mathmode. Detexify gives me only text mode symbol for LaTeX.

closed as off-topic by egreg, yo', Jesse, Paul Gessler, Svend Tveskæg Feb 3 '15 at 13:40

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 6
    Both @ and $@$ work for me. Can you provide an example of what you've tried or the mode of failure? – Steven B. Segletes Feb 3 '15 at 12:47
  • Ok, since you told me it should just work I went through my code and you are right. It was a parameter to a macro that inserted a backslash before it! - like this: \@ . – eri0o Feb 3 '15 at 12:51
  • Now it works. How do I close this question? @StevenB.Segletes – eri0o Feb 3 '15 at 12:51
  • 1
    Or you could reformulate your question if your additional probing has allowed you to distill the problem more precisely. Note that macro names (beginning with \) have special rules about their naming conventions, especially if it involves not alphabetic symbols. – Steven B. Segletes Feb 3 '15 at 12:54
  • 4
    I'm voting to close this question as off-topic because it's a non problem due to typing \@ instead of @ – egreg Feb 3 '15 at 13:10
7

As @StevenB.Segletes mentioned in the comments, plain @ should work, in math or text mode. I had somehow managed generate a \@ , which throws the following error:

! You can't use `\spacefactor' in math mode.
\@->\spacefactor

Corrected my code and now everything is working.

Not the answer you're looking for? Browse other questions tagged or ask your own question.