2

I have a few frames showing the same picture in the background but adding more pictures on top of it every frame. At each new frame, the subsection counter goes up by a dot. Is it possible to keep the same "dot" as the previous frame? that is, almost ignore the new frame in the counter?

I've tried \addtocounter{subsection}{-1} but that just removes the total number of open circles.

Any help will be appreciated. Thanks.

\documentclass[xcolor=dvipsnames]{beamer} 
\usetheme{Darmstadt}
\usepackage{helvet}
\usecolortheme{dove}

\setbeamertemplate{items}[default] 
\setbeamertemplate{blocks}[rounded][shadow=true] 
\setbeamertemplate{frametitle}{% 
  \nointerlineskip% 
  \large\bfseries
  \begin{beamercolorbox}[wd=\paperwidth,ht=1ex,dp=0.75ex,left]{frametitle}% 
  \centering\insertframetitle% 
  \end{beamercolorbox}}

\usepackage{amsthm,amsmath,amsfonts} % AMSLaTeX packages
\usepackage{graphicx} % we want to use images

 % remove navigation control
\usenavigationsymbolstemplate{}
\setbeamertemplate{footline} {%
  \leavevmode%
  \hbox{\begin{beamercolorbox}[wd=.5\paperwidth,ht=2.5ex,dp=1.125ex,leftskip=.3cm]{author in head/foot}%
    \usebeamerfont{author in head/foot}\insertshortauthor \end{beamercolorbox}%
  \begin{beamercolorbox}[wd=.5\paperwidth,ht=2.5ex,dp=1.125ex,leftskip=.3cm,rightskip=.3cm plus1fil]{title in head/foot}%
    \usebeamerfont{title in head/foot}\insertshortinstitute \hfill \insertframenumber/\inserttotalframenumber
  \end{beamercolorbox}}%
  \vskip0pt%
}


\usepackage{tree-dvips,graphicx,color,qtree,apacite,algorithm,algorithmic,multirow,tipa,vowel}

\newcommand{\subscript}[1]{{\textnormal{\scriptsize{#1}}}}  % for writing subscript text

\usepackage{textcomp}
\usepackage{setspace}
\usepackage{natbib}

%\renewcommand{\bibfont}{\tiny}


% TITLE
\title{ASDF}
\date{\today}

% BODY
\begin{document}

\begin{frame}
\setcounter{framenumber}{0}
\titlepage
\end{frame}

\section{Introduction}
\setcounter{subsection}{1}
\begin{frame}
\frametitle{SLIDE 1}
\end{frame}

** COMMENT: here is were I would like both frames below to show the same closed circle in the header denoting the same subsection. the problem is that a new frame fills a new circle denoting subsection.

\begin{frame}
\frametitle{SLIDE 2}
\hspace*{-0.45cm}\includegraphics[scale=0.46]{A.PDF}
\end{frame}

\begin{frame}[noframenumbering]
\frametitle{SLIDE 2}
\hspace*{-0.45cm}\includegraphics[scale=0.46]{B.pdf}
\end{frame}

\end{document}
5
  • 2
    Please add to your question a complete, yet minimal, document showing the relevant settings and allowing us to reproduce the undesired behaviour. Commented Feb 4, 2015 at 1:46
  • thanks! sorry about that. i added a rough layout. hope it helps. please let me know if you have any ideas.
    – trafalgar
    Commented Feb 4, 2015 at 2:05
  • 1
    You forgot some information: the beamer theme used and \begin{document}, \end{document}. Please always post complete documents. Commented Feb 4, 2015 at 2:41
  • To check your example is complete, compile it before you upload it and check that it demonstrates the problem you are asking about. Since the default theme doesn't involve circles at all, it is currently impossible to guess your setup.
    – cfr
    Commented Feb 4, 2015 at 2:50
  • thanks for all your replies. I updated the post to include the compiled code.
    – trafalgar
    Commented Feb 4, 2015 at 3:35

1 Answer 1

0

According to the description, you might be interested in overlays, so instead of two separate frames you'll have one frame with two slides: each slide containing one of the images; something along these lines:

\begin{frame}
\frametitle{SLIDE 2}
\only<1>{\hspace*{-0.45cm}\includegraphics[scale=0.46]{example-image-a}}
\only<2>{\hspace*{-0.45cm}\includegraphics[scale=0.46]{example-image-b}}
\end{frame}

A complete example (I removed parts of the original code that were not relevant to the issue):

\documentclass[xcolor=dvipsnames]{beamer} 
\usetheme{Darmstadt}
\usecolortheme{dove}

\setbeamertemplate{items}[default] 
\setbeamertemplate{blocks}[rounded][shadow=true] 
\setbeamertemplate{frametitle}{% 
  \nointerlineskip% 
  \large\bfseries
  \begin{beamercolorbox}[wd=\paperwidth,ht=1ex,dp=0.75ex,left]{frametitle}% 
  \centering\insertframetitle% 
  \end{beamercolorbox}}


 % remove navigation control
\usenavigationsymbolstemplate{}
\setbeamertemplate{footline} {%
  \leavevmode%
  \hbox{\begin{beamercolorbox}[wd=.5\paperwidth,ht=2.5ex,dp=1.125ex,leftskip=.3cm]{author in head/foot}%
    \usebeamerfont{author in head/foot}\insertshortauthor \end{beamercolorbox}%
  \begin{beamercolorbox}[wd=.5\paperwidth,ht=2.5ex,dp=1.125ex,leftskip=.3cm,rightskip=.3cm plus1fil]{title in head/foot}%
    \usebeamerfont{title in head/foot}\insertshortinstitute \hfill \insertframenumber/\inserttotalframenumber
  \end{beamercolorbox}}%
  \vskip0pt%
}

\begin{document}

\section{Introduction}
\setcounter{subsection}{1}

\begin{frame}
\frametitle{SLIDE 1}
\end{frame}

\begin{frame}
\frametitle{SLIDE 2}
\only<1>{\hspace*{-0.45cm}\includegraphics[scale=0.46]{example-image-a}}
\only<2>{\hspace*{-0.45cm}\includegraphics[scale=0.46]{example-image-b}}
\end{frame}

\end{document}

The result:

enter image description here

2
  • wow. thank you very much. I didn't know there was such an easy solution. I am very new to beamer (obviously) and I greatly appreciate your help. Thanks again for your answer and patience.
    – trafalgar
    Commented Feb 4, 2015 at 4:27
  • @trafalgar You're welcome! Glad I could help. Commented Feb 4, 2015 at 4:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .