0

I am trying to write a paper using the achemso document class for the first time. I had worked with LaTeX previously using a different document class (book) and I had only used the achemso package to keep track of the references and have the reference style as ACS requires it and I had had no issues.

When I attempted to use the document class achemso, however, I got a bunch of errors. First of all, it prompts me to the "\begin{document}" as being an error (I don't understand why) and then, after it runs everything, I am having issues with the bibliography, every time the program reads a citation, I have to click enter, and when I have 7 citations, it is kind of boring, but I actually have around 200! An then, when I go to the bibliography, I am seeing the title of the papers, which were not supposed to be included since I am supposedly using the achemso.sty style. Can anybody help?

I am attaching a MWE to see if anybody could help me with this. This is the link to get the bibliography: https://drive.google.com/file/d/0BxNftlsFB4P5bEtEaVVYd2YxeFE/view?usp=sharing

\documentclass[journal=chreay,manuscript=review]{achemso}

\author{Author Person}
\author{Second Bloke}
\email{second.bloke@some.place}
\phone{+xxx (0)yyy zzzzzz}
\fax{+xxx (0)yyy wwwwww}
\affiliation[University of Sometown]{University of Somewhere, Sometown, Country}

\usepackage{graphicx}
\usepackage{dcolumn}
\usepackage{multirow}
\usepackage[para]{threeparttable} %this allows for using footnotes in tables
\usepackage[printonlyused]{acronym}
\usepackage{SIunits} %incompatible with package chemmacros use siunitx instead
\usepackage{textgreek}%this is to use greek letters as part of a text, no math mode
\usepackage{chngcntr}%this is to change the counter
\usepackage[usenames,dvipsnames]{color}
\usepackage[table]{xcolor}%This highlights rows in a column by adding \rowcolor{color} before the row, but looks bad taken from http://timmurphy.org/2009/09/06/highlighting-table-rows-in-latex/
\newcounter{rowno}
\setcounter{rowno}{0}
\newcolumntype{.}{D{.}{.}{4}}%. specifies a column of entries to be centred on the ..
\usepackage[format=hang,labelfont={bf},margin=1em,labelsep=period,textformat=period]{caption}
\usepackage{subcaption}
\usepackage{url}
  \urlstyle{sf}
\usepackage{psfrag}
\usepackage[runs=2]{auto-pst-pdf}
\usepackage{chemnum}
\setchemnum{
  replace-style = \fontsize{8}{10}\rmfamily,
}
\usepackage[version=3]{mhchem}
\usepackage{enumitem}
\usepackage{rotating}
\usepackage{subfig}

\title[Example]{Non-working Example}
\abbreviations{IR,NMR,UV}
\keywords{American Chemical Society, \LaTeX}


\begin{document}

This is an example that works, except when you are trying to add some \textsubscript{subscript} text.\cite{Pinto:2005wp, Sousa:2005ug, ElSeedi:2009wq, ElSeedi:2010uc, YANG:2012hd, Masters:2012ds, Winter:2013bg}

\bibliography{Abbreviated}
\end{document}
  • On the article titles, you have explicitly set \setkeys{acs}{articletitle = true} so this is not surprising. For the other errors we will need to see your log, but before you edit that in I suggest you try to minimise your package use. As well as making the log and example smaller, that's a good idea for journal submission as you should use only packages and settings you absolutely need for that process. For example, you do not need hyperref, should not be messing with section numbering, should not be altering \clubpenalty, etc. – Joseph Wright Feb 5 '15 at 7:19
  • Thank you for your prompt response @Joseph. I wanted to use [{hyperref}] to be able to use [\autoref] and don't worry about writing: ``as seen in Figure/Scheme/Section... \{fig/sch/sec:mycode}'', but it seems that achemso does not support hyperref.I deleted some packages I was using and I don't see that error any more. However, I still get an error when I am trying to put some text as subscript by using [\textsubscript{this text}]. Do you know why this is happening? – amsterzone Feb 5 '15 at 19:49
  • The latest release of achemso should work with hyperref: what version of achemso do you have? On \textsubscript, it's not currently part of the kernel so you need \usepackage{fixltx2e} to use it (this will change soon!). – Joseph Wright Feb 5 '15 at 19:53
  • I have the achemso 3.8k version. Is this version also compatible with the {acronym} package? – amsterzone Feb 5 '15 at 20:11
  • Not really tested fully (I do warn about using any packages!), but demo seems to work. – Joseph Wright Feb 5 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.