1

Thanks for your help in advance. I am using LyX to typeset my dissertation. However when I export to plain LaTeX the problem persists, so I know is is a LaTeX problem.

I am using sidecap with ClassicThesis and I cannot (either using the LyX controls or by writing LaTex code) get figures to appear anywhere other than at the top of pages. Often it is convenient for me to have a small figure in the middle of the page. I have tried [h], [!h] and [H]. If I change the figure to a standard figure float then [h] produces exactly the result I would like.

Is there any way around this?

Yours in thanks, Thomas

EDIT: Found the cause of the issue here: How do I make the figure float [H] here when I use SCfigure?

In short, it turns out that the floating specifier is the second optional parameter of SCfigure, so to get the same behaviour as \begin{figure}[h], one should use \begin{SCfigure}[][h]

This is maddening! Turns out that I have a LyX problem after all. Unless anyone can shed any light here, I will take it to the relevant forum.

EDIT 2: It appears to be a problem with the sdecap module (link in the comments). I have tried the method described in the LyX EmbeddedObjects manual but it returns "File ended while scanning use of \@argdef." when I compile.

Any other suggestions?

EDIT 3: An example of what I am trying to achieve: A nice marginal caption

  • You can try the floatrow package which has captionposition=beside key, and also a capbesideposition={left/right/inside/outside,top/bottom/center} key. It cooperates with caption and redefines and extends float. – Bernard Feb 6 '15 at 0:02
  • Is there some module that you're using for SCfigure? If so, it sounds like a bug with the module, and you should contact the maintainer. – Torbjørn T. Feb 7 '15 at 22:32
  • Yes, I will try to get some support from the module author. I am not going to bet a dissertation on that though... @TorbjørnT. – Thomas James Mathew Feb 8 '15 at 14:10
  • For now I will try floatrow which sounds better anyway. Thanks @Bernard – Thomas James Mathew Feb 8 '15 at 14:11
  • @Bernard it seems like floatrow is not compatible with the float package which (I think) is built into classicthesis... So no luck there. Any advice? – Thomas James Mathew Feb 8 '15 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.