1

Could anyone tell me how to use \usepackage{ebgaramond-maths}? Here is the website of package,

 http://www.tug.dk/FontCatalogue/ebgaramond/

When I run PDFTeXify, there always show some font that can not be found. How to solve this problem? Please help me and illustrate detailed steps.

Here is the error information:

!pdfTeX error: pdflatex.exe (file EBGaramond12-Italic--oml-ebgaramond):

Font EB Garamond12-Italic--oml-ebgaramond at 500 not found

==> Fatal error occurred, no output PDF file produced! texify: pdflatex.exe failed for some reason (see log file).

Please help me.

  • How do you load the packages? (I would try \usepackage{ebgaramond,ebgaramond-maths}.) Which TeX distribution, and which vintage, do you employ? The reason I ask is that the ebgaramond-maths package is of fairly recent vintage. If you have an older TeX distribution, the package may not be installed (or installed fully). – Mico Feb 7 '15 at 14:17
  • As the compiler tries to make bitmap fonts, it looks like dvips.pdflatex are not aware of the type 1 fonts. You should run updmap or initexmf -mkmaps. – Bernard Feb 7 '15 at 14:22
  • 1
    @Mico You don't need to load ebgaramond separately as ebgaramond-maths loads it anyway. It looks as if the package is not installed properly. Current TeX Live certainly includes it. (In any case, if you are using TeX Live, do not run updmap ever if you can help it. Use updmap-sys if necessary.) Guessing this is a MiKTeX install, though, since MiKTeX seems often not to update the map files properly. If you installed the package using MiKTeX, Bernard's advice is probably good. – cfr Feb 7 '15 at 21:43
1

I recently had the same problem under Windows with Miktex 2.9. The workaround is pretty simple with Miktex.

  1. Launch the Update manager with administrative rights: Update (Admin) and follow the instructions to update your distribution.

  2. If the "ebgaramond" and/or "ebgaramond-math" packages are not installed, launch the Package Manager with administrative rights: Package Manager (Admin) and update the repository entries (Repository->Synchronize). Then install the packages.

  3. Launch the Miktex Options manager with administrative rights: Settings (Admin) and first hit Refresh FNDB, and then Update Formats.

  4. Restart your LaTeX document editor and compile. Everything should be fine after these steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.