3

I'm using Tikz to create some vector graphics images. I'm finding that when I compile my images to EPS (the preferred format of my publisher) the quality is significantly lower than if compiled to PDF. In this screenshot EPS is above and PDF is below:

enter image description here

(The PDF from which I took this screenshot can be viewed here.)

Why is the quality lower? Does the EPS format rasterize basic vector graphics elements like the circle? Or is my PDF reader at fault?

EDIT:

Even compiling the basic document

\documentclass[11pt]{standalone}
\usepackage{graphicx}
\usepackage{tikz}
\begin{document}
    \begin{tikzpicture}
        \draw (0,0) circle(2);
    \end{tikzpicture}
\end{document}

using pdflatex and then converting to EPS with pdftops gives the same look for each.

  • 2
    Please post a minimal document which can be compiled to reproduce the problem. EPS is a vector format. – cfr Feb 7 '15 at 22:09
  • 4
    You should compare the printed output, as it is more likely to be the preview of eps vs pdf that is the issue here. In particular, the pdf preview you showed has some sort of antialiasing, to get rid of the "jaggies" that are in the eps preview. See en.wikipedia.org/wiki/Jaggies Edit: I re-read your question - this all in a pdf viewer. My advice of looking at printed output stands, as it could be that your workflow converts .eps to (say) 300dpi raster, which look rubbish in Acrobat, but print OK. – Andrew Kepert Feb 7 '15 at 22:58
  • Have you tried the method described on page 617 of the TiKZ manual? This uses externalisation to produce EPS output by calling latex rather than pdflatex to produce the images. [But I tend to agree with @AndrewKepert that this is likely a viewer issue. Also, there are various ways of controlling the output of pdftops - it is just a ghostscript wrapper, after all.] – cfr Feb 8 '15 at 3:29
2

Here is the output from your MWE on my system:

PDF:

PDF

PS:

PS

So this certainly looks fine here.

\documentclass[11pt,tikz,border=5pt]{standalone}
\begin{document}
    \begin{tikzpicture}
        \draw (0,0) circle(2);
    \end{tikzpicture}
\end{document}

Note: The slight unevenness in both cases is the result of conversion to PNG for upload here. Both originals are smooth circles. I can't zoom the postscript as far but I think that is a viewer limitation.

| improve this answer | |
  • The problem does seem to be my document viewer, confirmed with a few print-outs that showed the EPS and PDF as the same. Thank you! – James Fennell Feb 13 '15 at 13:58
1

It is not really an answer but there is something wrong in your pdf. I opened it in Illustrator to have a look at how your objects were created. As you can see below, the pdf circle [right] is a set of few splines (fine) while the ps circle [left] is a set of many small disjoint black dots (bad). If you used Tikz for both, my guess is that there is something wrong with your postscript driver. In an ideal world, the two objects should be defined by a few splines and then look the same in Illustrator or Inkscape.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.