1

I am using the following command in a .cls file:

\RequirePackage[numbers,sort&compress]{natbib}

for references.

I do not know why the output of the compilation shows an additional rectangle.

enter image description here

Further information:

in the .cls file I use:

\RequirePackage[unicode=true, pagebackref=true]{hyperref}

in the main file main.tex I use:

\bibliographystyle{ieeetr}
  • 2
    A minimal example is necessary. – egreg Feb 9 '15 at 11:46
  • 1
    this is just a conjecture. when references are compressed, there's no way to link the "missing" ones. it's likely that the "extra" rectangle is the result of an effort to recognize that limitation. – barbara beeton Feb 9 '15 at 12:45
  • I have just checked out all the references. There are no missing links. – no_name Feb 9 '15 at 19:36
  • I am utterly unable to reproduce the problem you report getting. Please, please tell us which document class you use, which bibliography style you employ, and which other citation-related packages (if any) you load. – Mico Feb 9 '15 at 20:10
  • Thanks for providing information on the bibliography style and the options passed to the hyperref package. There must be something more going in the the class file and/or in the preable of your document, as I continue to be unable to reproduce the problem you say you're getting. – Mico Feb 9 '15 at 21:17
2

I fixed the problem. It seems that it was a conflict between natbib and hypernat. I have just removed:

\usepackage{hypernat}
  • The hypernat package hasn't been updated since 2001. Moreover, its user manual states "This package will disappear from the CTAN, when natbib will do the job by [it]self." In short, it should not be used by anyone unless they must use a 14 year old TeX distribution... – Mico Feb 11 '15 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.