1

I installed TeXLive 2014 complete from a DVD on Fedora 21. I have set the PATH as per the instructions to /usr/local/texlive/2014/bin/x86_64-linux and it is working correctly.

While installing auctex for Emacs via yum, it created another install of texlive in /usr/share/. Now the problem is that when I run udpmap-sys to update the fonts it writes to the /usr/share/texlive/ instead of the /usr/local/texlive directory. Same is true with mktexlsr.

So result of this is that I cannot use the new fonts that I have installed, as they are updated in the /usr/share/ folder instead of the /usr/local where the main TL2014 install is.

Is there a way to resolve this? So that updmap-sys and mktexlsr write the files to the /usr/local/ instead of /usr/share directory?

  • 1
    i put the path to the tex binaries at the start of the global search path list. in fact, i go so far as to have an alias to a command that does that, i my login script; of course it has to be a shell command — mine is actually export PATH=/local/cache/texlive/2014/bin/x86_64-linux:$PATH – wasteofspace Feb 10 '15 at 10:59
  • A second option, untested since I have no Fedora systems: texlive dummy package. – Mike Renfro Feb 10 '15 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.